Go Down

Topic: Due - cant associate com port (Read 2913 times) previous topic - next topic


new Due board.  win7, 32 bit, up to date with patches.

Installed driver as per instructions.  It comes up in devmgr as "Arduino Due Programming Port", but it does not have a COM port associated with it in the tree display.

goto device properties/advanced to associate/assign a com port to it, and when i try to set it to anything, the devmgr takes an exception/stops working and closes out.   It has COM 1 assigned to it by default however that is in conflict with an existing COM port.  navigating to advanced settings for device, tried to assign it 18,19, 23... same result, devmgr stops working dialogs come up and i'm toast.

reboot/uninstall, removing driver/re-install etc all tried.  same.   Everthing appears to go fine, but no com port associated with the device as one would expect.

and of course (no surprise) cant download a sketch (all im trying is blink example). 

been working with UNO R3's and Nanos just fine (on other ports).

any help out there oh Obeewans of Due?

Louis Davis

It's not clear from your post if you have followed these steps to install the com port drivers:

Right click the "Arduino Due Programming Port" in Device Manager
Select Update Driver Software
Select Browse my computer for software
Click Browse button
Select the Drivers folder under the location of your Arduino software installation. (Do not select the FTDI folder inside the Drivers folder)
Click OK
Click Next


Hi Louis,
tnx for the reply.  yes i did follow the steps to load the driver via the "update driver" as you indicate below everything seemed to go fine (and i have tried ununstalling the driver and doing it again).  Thats the only way it can appear in the serial ports of the devmgr as "Arduino Due Programming Port" i think.   It moved from "Bulk-In,Interface"  in "other devices" to  "Arduino Due Programming Port" in the "ports" branch of devmgr after the driver update.

i still have a "bulk-in" interface showing (probably the second port of the Due?) in the Other Devices branch.

40+ viewers and you were the only one to reply... thank you

i included a little jpg of the devmgr output. 



i removed and uninstalle the driver, and included a look at the devmgr BEFORE i install the driver.  Immediately after scanning for new hardware, two items show up in the "other devices" node of devmgr.

after installing the driver, the "Arduiono Due Prog. Port" moved down into the "ports" node of devmgr as shown in the previous response.

just thought i'd show you a before and after perspective.  Notice that on the "after" perspective no "COM" port is assigned in parentheses.  and any effort to do so results in the devmgr taking an exception and crashing out.  This does not happen with other devices (i tried it to ensure it wasnt something with the devmgr).  I suspect an invalid reference is getting returned to devmgr in some way from the driver.

here is the "before" view of devmgr.  The Eltima VSP's are used for my MicroKeyerII interfaces - and it works fine.

Go Up