Go Down

Topic: Serial menu disabled - Arduino IDE on BeagleBoard running Ubuntu 12.04 (Read 2068 times) previous topic - next topic

theworldtrekker

Nov 09, 2012, 09:07 pm Last Edit: Nov 09, 2012, 09:32 pm by theworldtrekker Reason: 1
Fixed: creating a new serial port and linking it to /dev/ttyO1 worked (ln -s /dev/ttyS1 /dev/ttyP1) allowed Arduino IDE to see the onboard UART on the BeagleBoard.

Wondering if anyone has experience and can help with getting the Arduino IDE (v 1 or 1.0.1) to recognize the onboard serial connections (/dev/ttyO1) on a BeagleBoard? Looking for an easy way to upload new code to the Arduino on a BeagleBoard Trainer board without having to program it via its ISP connector from another computer.

Unlike many of the other mentions of similar issues with this on this forum, Arduino IDE recognizes a USB connected Arduino, but not one connected via /dev/ttyO1 on a BeagleBoard Trainer board. If I don't have a USB Arduino plugged in, then the Serial Port menu is greyed out. If a USB Arduino is plugged in, then the menu works as does the Serial Monitor.

I know the board is connected correctly because an Angstrom distro with Arduino IDE can talk to it fine on the same BeagleBoard, it just can't program it due to a GLIBC (/lib/libc.so.6) version issue (it only wants 2.11 but 2.4 is installed) keeps it from compiling Arduino code.

It isn't a permissions issue that I can find (tried it as su, member of dialout, etc), /dev/ttyO1 is configured correctly and I can communicate with the Arduino chip via bash serial session without problem. Rather the problem seems to be that the Arduino IDE specifically excludes /dev/ttyO1 and /dev/ttyO2 from its available serial ports. Is there a way to enable them? Setting it in the .Arduino/preferences.txt file has not effect except to change the text at the bottom of the Arduino IDE, but still the Serial Port menu is greyed out. Trying Serial Monitor at this point generates: processing.app.SerialNotFOundException: Serial port '/dev/ttyO1' not found.

I've tried both openjdk v 6 and 7, no difference. I've made sure I'm running the latest version of librxtx for armhf and that the Arduino IDE is referencing it, not a general linux 32-bit one.  

jdcravens

I am in the process of figuring this out on the Beaglebone. Were you able to get Arduino IDE built and working on the Beaglebone?

theworldtrekker

Please note that my post was about a BeagleBoard not Beaglebone.

For this, I am running a full version of Ubuntu 12.04, which I understand is not desirable on the Beaglebone due to the lower processor/RAM specs, although can not confirm since I do not have one. Because of this I was able to get the Arduino IDE running, it only required creating a link in Ubuntu for port ttyS1 from ttyP1, which is  the onboard serial port I have the Arduino connected to. This was using a pre-compiled version of Arduino IDE from the Arduino site.

Go Up