Go Down

Topic: Is my Arduino broken? [serial port already in use problem] (Read 18231 times) previous topic - next topic

Toanhan

#15
Jun 05, 2014, 09:43 pm Last Edit: Jun 05, 2014, 09:53 pm by Toanhan Reason: 1
Hi all,
first of all sorry for my poor english.

i solved my "serial port already in use" problem
but, there are lots of reasons for this problem, so my way can just help a few of you who has the same reasons.

cast:
-me
-arduino uno r3
-vista 7
-an unknown device using com3

Problem:
Arduino IDE software gives an error message as "serial port already in use" and don't load the sketch to Uno R3.
In system/device manager, COM3 is belongs to Arduino Uno but my Arduino gives an error as COM3 is using by another device.
A schizophrenic reaction.

Reason: i tried to fix this "serial port already in use" problem for 2 weeks but couldn't.
I tried lots of softwares and different methods to fix the com port problem.
but all of them was unsuccessful.


Than, i remembered that a few weeks ago i removed a flash disk from usb drive of my laptop without using the "remove device safely" function. At this moment windows writes an error code in the system and waits for the correct device again to delete this code.

With this error, any device, a gps or another flash disk can be used safely without an error.
Also you can connect the Arduino without any error message.
But system detects a virtual device (possibly the old removed flashed) at the same port and blocks the IDE data transfer to Arduino board.

The point here is, Arduino gives the error as COM port problem, but the problem is about USB connection.
So the user focus to a wrong point and works on COM ports.

Solution:
If you  blow away this error code in the system, your problem will be fixed.

This is the way:
Write "regedit" to start/run and open it.
At opening window you will see a group of folders left side.
Choose   HKEY_LOCAL_MACHINE \ SYSTEM \ Curr entControlSet \ Control \ Windows \ ErrorMode

Right click to ErrorMode and open.
Than change the number (0) to (2)

(If its already (2) dont make any change, this means
your problem is not an USB connection problem so
my method will not help you to fix this problem)


Restart the computer.

First connect your Arduino to USB, than open the IDE software.
Load your sketch.

Have a nice project ;)





Go Up