Go Down

Topic: Uno don't connect but Duemilanova does (Read 895 times) previous topic - next topic


Yip you read it right.

My Uno rev3 doesn't connect in Windows 8 but my Duemilanova does.

I use the same FTDI drivers for both of them. Tried to change the settings of the usb port but still the UNO doesn't connect.

I don't know what more I can do except that it could be that the UNO is some how corrupted and has a bug in it some where. Or my UNO is defective some how.

Can some one please help me in understanding why the two are so different in connecting to my laptop with Win 8 on it?

With the UNO I get a blinking orange light "L" and with the Duemilanova I only have the power light and when I connect to program the ATMEL not a problem with it.

With the UNO I can't connect so I can't program it.

I tried the blinking LED on both and only on the Duemilanova does it work.

Win 8 regonice that there is a new part, and can give it a comport letter. But when I try to  connect with IDE I can't.

And with the UNO it says it doesn't have a signed certificate from windows and there for can't use the drivers.

But then again the Duem use the same drivers basically and can connect through the IDE.

So something isn't working right or getting to my head.

Any help will be appreciated big time


just ignore the win message saying it cant use the drivers and load it on anyway .
try another 328 chip on the UNO(with BL)

Louis Davis

The UNO does not use the FTDI chip...

Follow the steps here to disable driver signature enforcement on Win8:

Then follow these steps to install the UNO drivers:

Right click the Unknown Device in Device Manager
Select Update Driver Software
Select Browse my computer for software
Click Browse button
Select the Drivers folder under the location of your Arduino software installation. (Do not select the FTDI folder inside the Drivers folder)
Click OK
Click Next

Go Up