Go Down

Topic: SIG_USART0_RECV (Read 1 time) previous topic - next topic

99kx

Arduino 1.0.1
avr-gcc 4.7.2-1
avr-libc 1.8.0-1

Computer: 2Ghz P4 2G RAM Dell Laptop
OS: Fedora 17

User Level: Total Novice

Problem: Can't compile/program board

Error: /usr/share/arduino/hardware/arduino/cores/arduino/HardwareSerial.cpp:101:15: error: attempt to use poisoned "SIG_USART0_RECV"

History: It worked when I installed it. I did my fedora 17 updates and thats when it stopped working (I believe it might have been avr-libc that broke it). I'm quite certain it worked with avr-libc 1.7.1-3.

What I tried to fix it: I did much searching and came up with a couple of files that are suppose to be modified but it looked like they where already setup the way they suggested.

I found this http://code.google.com/p/arduino/issues/detail?id=955 that's suppose to fix the problem but I have no idea how to use it. I'm not a programmer and this stuff is all new to me. If I can either get some help with either installing that fix or just putting avr-libc 1.7.1-3 back on I sure would appreciate it. Thanks.


Go Up