Go Down

Topic: avrdude: stk500_getsync(): not in sync: resp=0x30 (Read 27928 times) previous topic - next topic

set435

Um help? I tried to burn bootloader but it said avrdude = not in sync resp 0x30 and I know someone is going to comment read it again! But, um, help at least? ^___^

railwaybob

#16
Jun 11, 2014, 10:56 am Last Edit: Jun 11, 2014, 11:00 am by railwaybob Reason: 1
So you've tried to upload your program to your Arduino and are getting the error message
avrdude: stk500_getsync(): not in sync: resp=0x30

It seems that, periodically, the Arduino software decides to use a different COM port, especially if you've restarted your computer.  Your problem seems to be that your Arduino isn't connected to the proper COM port.  Or rather, your computer is connecting to a COM port that isn't the same one that your Arduino is connected to.  

Take a look at the bottom right corner of your Arduino program page.  In white you will see the COM port that your computer is trying to use.  It will probably be COM3.  Your Arduino is probably connected to another COM port (Make sure your Arduino IS connected to your computer via your USB cable!).  

Solution:
Click on "Tools"
Click on "Serial Port"
From the drop-down box, you might see two (or more) COM ports.  
One of those COM ports has a check-mark beside it.  
The other COM ports are unchecked.  
Click on one of the unchecked COM ports.  
The check-mark moves to this new COM port.
Upload your program to your Arduino.  

If unsuccessful (assuming you have more than two COM ports listed under "Serial Port"), repeat the above using a different COM port.  If you've only got the two COM ports listed, then your problem is something other than the above.  

Hope this helps.

Bob M.

PS - Make sure you've tried to upload your program to your Arduino in the current session.  If you've restarted the Arduino program but haven't tried to upload your program to your Arduino, all of the available COM ports may not be shown when you click on "Tools", "Serial Port", etc

Go Up