Go Down

Topic: This problem for people about "Not in sync" error. Any updates? (Read 8775 times) previous topic - next topic


At the risk of getting myself in trouble I shall ask.

I am reading that people are having trouble uploading sketches to their Arduinos.

I now have 4 and only 1 works.

1 is maybe dead, but I can still upload the basic BLINK sketch and it works.

The other two new ones just won't "sync".

I have tried different computers, different drivers, different board names.

Nothing works.

I chanced doing a flash of my alarm clock and it still works.  I can upload sketches to it.

So to me that says the computer/laptop is still ok.

But now what?



You could take the 328 chip out of the working one and put it in each of the other Arduinos to see if that revives them.  Check for proper 5V on each board before putting the good 328 in and make sure nothing else is connected.  If the good 328 makes the other boards work, then it may be a corrupt bootloader on the bad ones.  You could then use the good 328 to re-burn the bootloader on the sick ones.


Dec 13, 2012, 09:39 pm Last Edit: Dec 13, 2012, 09:43 pm by lost_and_confused Reason: 1
Yeah, but that working is my alarm clock, and I can't exactly afford to risk it.

I have taken my laptop to one of the shops and tried many other Arduino boards, all with the same result.  They are not in sync.

So the problem seems a bit more wide spread than the two cards I have, and my laptop.


Dec 14, 2012, 02:46 pm Last Edit: Dec 14, 2012, 03:17 pm by BillO Reason: 1
How about a different USB cable?  I've have at least one that got damaged or worn and would not work on some device but would work fine on others.

It's unlikely that every Arduino in your neck of the woods is bad.  It's more likely that it has something to do with your set-up.  The common denominators are your laptop and the USB cable (I'm guessing on the cable, but it is cheaper to replace than your laptop).

Failing that, can you see your way to buying a new 328 with bootloader on it?  There are places that sell them for under $5.  If this fixes one of your dead boards, then you can use it to try to burn new bootladers onto the other two bad chips.


I have been using Arduino boards for years and never received the not in sync error.  For people having the issue:  something is happening to the 328 itself or the bootloader is getting damaged, which leads to the problem.

That "something" can be a huge list of things.  It could be something so minor that you don't even remember doing it.  E.g. changing connections while the board was powered.  (Yes, I'm sure you'll argue you've never done that.  Everyone says that, but everyone does it at least once.)  My point is, seemingly minor actions could have caused damage.  Damaged components don't fail immediately.
Capacitor Expert By Day, Enginerd by night.  ||  Personal Blog: www.baldengineer.com  || Electronics Tutorials for Beginners:  www.addohms.com


I've got a total of 4 "IDE"s, the real one and three others.

I tried to load a program today and the three others get that error while the Arduino IDE does not.

Nothing changed in the cable, board or anything, just different IDEs all of which have worked before.

Not that that 's your problem, but something in the system is very flaky.

Rob Gray aka the GRAYnomad www.robgray.com


I teach with Arduino and I see a couple hundred boards in a year. I had purchased a batch from a local supplier that were darker blue then the regular Arduino boards and that have a red power LED. Since this purchase i have had some students by the same boards off of Amazon. The boards all say made in Italy but are not official arduino boards, they resemble a lot of the made in china knock off stuff . Any way every single one of them has giving me the "Not in sync" error at some point in their lives. I can change the 328 but eventually, "Not in sync" re appears. Most these boards have hit the trash in my class room because they got to frustrating to trouble shoot with students. 

Check the board for a red LED, it could be a knock off board sold to you as the real thing.


binning the boards seems rash ,better to salvage the parts and build a breadboard version to test the parts .i have bought chinese copies off ebay and theyre exactly the same as the originals .


I have a Chinese knock off, it works as well as an Italian one.  If swapping chips around points to the chip, burning a new bootloader on it tends to sort things.  Its not too difficult is you've got another working Arduino.  Reading the 'ArduinoISP' sketch in the examples in the IDE yields clues or http://arduino.cc/en/Tutorial/ArduinoISP .


It could have been the batch that i had. For me it makes a lot more sense to help students with their projects on stable platforms then running around troubleshooting and and burning boot loaders. When you are teaching you to minimize any thing that will frustrate students. Plus i would rather pay for the Arduino brand boards, they developed the boards and supporting them means more advances and cooler things.


Ok, the long winded story of "what happened":

I bought a board.  It worked.
Either computer.

Alas it was an Ether TEN board and the shield didn't fit over the RJ45 connector, so I bought another "UNO" equivalent.
It too worked.  Either computer.

The UNO is used in my alarm clock - the main reason I got into Arduino.  It works.
Nowadays it is only programmed from my laptop.
It still can be.

The Ether TEN board was being used in my potted plant watering system and I accidently  fried it.  Power on non-power pins.

It sort of works, but does silly things now and then.  Too unreliable.

I bought another "UNO compatible".

This one won't flash sketches on either computer.
I took it to a mate's place who is into Arduino and it won't flash there - same error.   To me:  Pointing to the board.

Suspecting the board, I went back to the shop - with laptop - and tried another board.
The boards at the shop have different connectors on them, so a new cable had to be used - supplied with the board.

So:  So far I know:
The laptop can flash my alarm clock.  (No, I can't start swapping chips.  I need the alarm clock.)  But the cable works, the laptop works, and the board work.

New board:  It has this NOT IN SYNC error.
Went to shop, new board, new cable.
Tried another board - this time an Ether TEN.


Went to another shop and bought a genuine UNO.
This has yet another connector type.

Got home.


Tried on other computer.


This is:


I get my old Ether TEN board - which had my old plant watering sketch.
Flashed the BLINK sketch.

LED 13 blinks.

Flash it with my sketch.  LED 13 stops blinking.
Flash it with BLINK and it starts blinking again.

PROVEN:  The machine can talk to the boards ok.

When I try to flash BLINK to the new board, the RX/TX LEDs do blink a bit, but not as much as with the Ether TEN board, and I get a NOT IN SYNC error.

Try the BLINK sketch on the Genuine UNO board:  SAME.

Tried changing the BOARD TYPE in the IDE.     SAME.

Have checked Device manager and I am selecting the correct COM port.  The board is listed and is known.

Other things to mention:
I have both 1.0.1 and 1.0.2 installed.
NEITHER ONE can upload to the two new boards.

Indulge me:
What speed do the com ports have to be set at?

I did notice I can select the board type/name and the com port, but not the settings like speed, parity, stop bit, etc.

Though I guess if I can flash the BLINK to my faulty Ether TEN, the settings should be ok.


Alas it was an Ether TEN board and the shield didn't fit over the RJ45 connector, so I bought another "UNO" equivalent.

So you bought non-Arduino supported hardware?

This might help narrow down your problems.
Capacitor Expert By Day, Enginerd by night.  ||  Personal Blog: www.baldengineer.com  || Electronics Tutorials for Beginners:  www.addohms.com



Well, yes and no.

The original board/s I bought (two of them) were Freetronics boards.
They both worked.
One was their UNO equivalent and one was their Ether TEN.
The third board was also an UNO equivalent but was a different board.  It has prototype area on it.
It doesn't work.
All the other boards in the shop (from Freetronics) didn't work.   They also have different connectors on them.   So that eliminates the cable.

I then tried the board on someone else's computer and it didn't work.

Now I have bought a Genuine UNO and it too doesn't work.

It is strange that at about that time other people started getting the same error.

To me that seems like a bigger bug than it being the board I bought, or my PC/s.


I'll go out on a limb:

I see there is a 1.0.3 IDE available.

I also read that it needs
.Net Framework 4.0

I just tried with 1.0.1 - which used to work and it now doesn't.

But if I am to move up to / on to the new GUI/IDE, I will need that installed.

I have only just got access to the "interweb" and don't now if I have that installed.

I have XP SP3 and I am getting "updates available" but they are UPDATES, not installs.

How/where do I get this .Net Framework 4.0?

I shall ask Mr Google as well, but this may be a factor for not only me but others - which is why I am declaring it here.


I also read that it needs
.Net Framework 4.0

Where in the world did you read that? Citation link needed, otherwise it didn't happen.  :D


Go Up