Go Down

Topic: Arduino 1.8.12 crash on startup ..(SOLVED) (Read 976 times) previous topic - next topic

patmolloy

May 20, 2020, 04:51 pm Last Edit: May 21, 2020, 02:48 pm by ballscrewbob
I re-insalled from scratch, but same issue .. I ran the debug version and got this ..

Code: [Select]
C:\Program Files (x86)\Arduino>arduino_debug.exe
Set log4j store directory C:\Users\patmo\AppData\Local\Arduino15
Loading configuration...
Initialising packages...
java.lang.NullPointerException
        at cc.arduino.contributions.packages.ContributionsIndexer.parseIndex(ContributionsIndexer.java:134)
        at processing.app.BaseNoGui.initPackages(BaseNoGui.java:483)
        at processing.app.Base.<init>(Base.java:273)
        at processing.app.Base.main(Base.java:150)


Would be most grateful for a pointer as to what has gone wrong and how to fix it.

Thanks!

ballscrewbob

#1
May 20, 2020, 05:06 pm Last Edit: May 20, 2020, 05:06 pm by ballscrewbob
is that the whole error ?

The second link has some tips that may be of assistance.

Could you take a few moments to Learn How To Use The Forum.
Other general help and troubleshooting advice can be found here.
It will help you get the best out of the forum in the future.

It may not be the answer you were looking for but its the one I am giving based on either experience, educated guess, google (who would have thunk it ! ) or the fact that you gave nothing to go with in the first place so I used my wonky crystal ball.

patmolloy

Thanks, yes that was the whole error message.

It turns out this was not version related, but related to a corruption somewhere in the additional boards definitions.

I deleted the relevant package files in the \AppData\Local\Arduino15 folder, and order was restored!

Pat

Go Up