Go Down

Topic: Problem Uploading: Maybe it isn't a butterfly/AVR109 but a AVR910 device? (Read 18616 times) previous topic - next topic

Pavz

:) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :)  Okay, so basically every time I try to upload to the board using the Arduino IDE 1.0.1 Software, it waits ages to upload then says:

   Binary sketch size: 7,660 bytes (of a 28,672 byte maximum)
   Found programmer: Id = "B¾ý"; type = 
   Software Version = . ;  Hardware Version = .
   avrdude: error: buffered memory access not supported. Maybe it isn't
   a butterfly/AVR109 but a AVR910 device?

So I'm a new guy to all of this just to say. It is really annoying me now...
I will be so happy if someone can help solve the issue, thanks in advance... :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :)

PaulS

Quote
every time I try to upload to the board

Perhaps you need to go look at the Products tab on the home page, and see just how many different "the board"s there are.

One smiley face is more than enough. A bazillion of them won't get you more attention. Don't do that again.
The art of getting good answers lies in asking good questions.

Pavz


PeterH


stefanmarggraff

Hi guys..

I am still experiencing the same problem as described above.  I have tried several different computers..all running on windows...please help!

I am using the new Arduino Robot..which appears to be similar to Leonardo.

Thanks
Stefan

little_o

Hey, I've had the same Problem and almost thaught my board was defect...
what finally helped me and I was suprised I've not found it anywhere on the internet was
changing the Programmer from "AVRISP mkII" to "USBasp"

I hope, I helped you, best regards,
Oliver

bruce87020

I've been having the same problem:  "Found programmer: Id = "B§$ "; type = Software Version =  . ; Hardware Version = .avrdude: error: buffered memory access not supported. Maybe it isn't a butterfly/AVR109 but a AVR910 device?" I'm using a Windows 8.1 laptop and have been trying to run the Logo program on the robot, which worked OK at first. (I haven't modified it.)

Unfortunately, changing the programmer from AVRISP mkII to USBasp didn't fix the problem. I also tried AVR ISP with no luck. (So far, I've only tried changing programmers on robot #2.)

I bought two Arduino Robots for my students. Robot #1 didn't have any program uploading problems for about a week. Now, however, I continue getting the above error message. Robot #2 only worked for one or two uploads and then started giving me the above error message. Same results when I switch to an XP machine.

My computer often switches the COM port, but I unplug the robot and see which COM port disappeared, then choose it.

For both robots, the "LED/RX" LED flashes for about four or five seconds after compiling is finished. Then, it stops flashing and I have a long wait before getting the above error message.

bruce87020

I forgot to mention that I uninstalled the Arduino software and then downloaded a fresh copy from the Arduino website. No luck with this, however.

stefanmarggraff

I struggled to get uploads to my robot for almost a week.
What worked for me: Press upload on the software interface; press and hold the reset button on the robot, until you hear the "USB-out" noise from your PC; release the button and it should work.  Another method would be to keep the reset button pressed until the IDE shows: 'Uploading', and only releasing it then.

I found that playing around with the reset button and trying to upload several times will work after some time.

Hope this helps.

darren_lewis

I'm having the exact same issue...
I've tried the reset approach - I couldn't get it to work...
I've tried several computers - including Windows 7/8 and Mac...

Does anyone have any other suggestions? Is my Arduino Robot faulty?

jaymiejames

high did you resolve this problem, i received my arduino robot today and i get the same.
thanks

jonnolly

Hello, I'm experiencing the same problem and was just wondering if it was resolved in the end.

Thanks
John

Ingeborg

Hello Robot User!
The same problem with Version 1.0.5 and an Windows XP PC.
The other problem with the same Robot on Windows 7 and Version 1.5.7 is today posted under Troubleshooting/Installation (unknown device).
Thanks in advance!
Ingeborg

stefanmarggraff

It is some kind of driver problem with windows.  I figured that mine decided after some time to install the correct driver.  I dont know why it worked all of a sudden.  Now it works on one of my USB ports. Good luck.

tc429

wish I'd researched a little before buying the kids a 'official arduino robot' to learn some programming on... worked fine till 7th sketch load, the P.O.S. is doing the same as all the ones listed above. got it to load one time since by the double reset at a certain time just after compiling, but took a couple dozen tries... sad, it ended up such a waste of two hundred bucks, looks like a perfect learning tool/toy- except they are all defective.

shoulda got them the starter kit and a couple motors.

is ANYONE at Arduino even looking into WTF is wrong with these? has anyone figured out a way to fix it on their own?

look forward to any info, else its ship it back and order something else...

Go Up