Go Down

Topic: Problem Uploading: Maybe it isn't a butterfly/AVR109 but a AVR910 device? (Read 18633 times) previous topic - next topic

tc429

well, after a couple MORE hours dicking with this thing, the kids and I found (just guessing/watching the led/timing to compile) if you do a double reset, wait for disconnect, wait for reconnect, wait 5 seconds(depends on time to compile sketch before load) then hit send... if you time it just right, the led will flash at about the time the thing changes from 'compile' to 'loading', then the two leds come on (like it did new/for the first 6 sketches loaded) and it will load.

our youngest is excited to see it do anything again, but this sucks.

arduino robot control board / 1.0.6 running on another computer(yesterdays 'fun' was with XP, this one is 8.1, but both act the same)

tc429

boy this forum looks kinda dead, see lots of new topics/very few responses... are the folks that make the arduino on this board often/are they looking into these bugs? just ordered a Uno, hoping it works better than the robot top board...couldnt be much worse- hard to imagine a device marketed for learning/programming can have so many issues with simply loading...so many threads with similar issues :(

Aerocell

I see I'm not alone with this problem, it's very sad because the Arduino Robot wasn't cheap especially for a Student, I need the Arduino robot for school but it won't work :( . I already installed VirtualBox to install Arduino on an other OS like WINXP but it doesn't work too, I'm using Arduino on Win7Ultimate. It seems like there need to come out a new Driver Update to clear this problem (Sorry for my bad English but I'm belgian)

tc429

anyone hear of any responses from the Arduino folks about these 'robot' upper board loading issues?

we bought a uno and a couple megas, they are awesome, can see making a lot of test tools out of these...working on one now for a yaskawa encoder, using the arduino to extract the brushless servo 'hall' outputs which they hide in a multiplexed output along with the quadrature...being able to test/adjust these without a scope would be great :)

hoping to eventually get the little robot fixed for the kids to work with- the double reset/wait/send thing works about 1/3 of the time, oddly if you succeed in loading it more than once, it seems to fix itself again for 5-6 more normal uploads, the the butterfly error thing comes back again...

Aerocell

I think I know how you fix the problem, when you are uploading a sketch you need to press the resett button several times and when u get a white sreen you can upload a sketch ;)

ruggb

i just ran into the same problem with a Mega 2560 bd i bought for a 3d printer..............
so when i connected it to W7 it loaded the driver. - so i decided to load the driver specified for the bd
The when i tried to upload again it told me i did not have a bd selected - did not do that b4 i loaded the speced driver.  works fine now.
Maybe u have to load a drvr like CH341ser and/or u have the wrong bd selected

alexkyriak

I had this error message. Solved it by going to Serial Port COM3, and USBasp under Programmer. Running Leonardo on Arduino 1.0.5.

Go Up