Go Down

Topic: womarts LCD touch (Read 12017 times) previous topic - next topic


I just got one of these boards (the Mega version).

It works with the UTFT libraries out of the box, no modifications needed.

Problem: does it really use all those pins?  my project is using the SPI pins and the Womarts board plugs into the entire set of pins on the bottom of the Mega.  So I'm not sure if I can use SPI and this board at the same time..


Hi, Orly_andico,

Can you please post the picture of you TFT (both front side & back side). I also bought the Womarts 3.2" TFT shield for Arduino Mega but so far I am not able to make it work. Would like to compare mine with yours.



Mine showed up today.  Having only used the Uno previously, I had two minor stumbles, after which the womart LCD worked.

1.  I neglected to select the board type under Tools in the Arduino menu, so PORTA and PORTC were reported as undeclared
2.  I had to install the USB driver from the Arduino drivers folder (fixed via directions at: http://9thsense.com/arduino-instruction/)

So other than those rookie mistakes, it works fine.

The demo code that womarts provided is outdated, and I couldn't make it work.  However, the newer TFT library from http://www.henningkarlsen.com/electronics/library.php?id=51 worked perfectly.  Likewise the UTouch from Henning http://www.henningkarlsen.com/electronics/library.php?id=55 works just fine.

So the womarts offering seems to be a pretty good deal at $15.00! (Oops, I see they are going for $21.50 now.  Inflation is rampant!)

Edit:  I didn't have the pin alignment issues Deltac0 described.  Mine mated up perfectly.  I also note the Mega board I have is apparently a clone as well, having a two-circle logo instead of the stylized infinity symbol of the genuine Arduino part.  That would explain how aliexpress.com can sell them for $15.  I suppose they are free to make their own boards and sell them, but it's rather shameful to counterfeit the logo.

Edit2:  I just went through the exercise of testing the SD card aspects.  After changing the (two!) reference from 4 to 53 in Cardinfo example, it worked just fine.  At first I didn't realize the card pushes in, clicks, but then must be pushed in further to latch it into place.  Until I did that Cardinfo couldn't access the card.


Can you please send me the womart Library, so far my screen just shows white background, even without any program uploaded to MEGA. Henning library is also not working. Ive tried all the models listed with myGLCD command.


Go Up