Go Down

Topic: Broken/unprogrammed UNO R3? =( (Read 32717 times) previous topic - next topic


Jan 08, 2013, 09:23 am Last Edit: Jan 08, 2013, 09:30 am by memorex Reason: 1

Yesterday my brand new (and first) Arduino Uno R3 arrived.
But when 1 plug it in the USB, i don't get the expected blinking led.
Instead the power led and the led close to pin 13 both stay on all the time. The power led is green, the other one is yellow.
I've read some things online that this might mean this Arduino is unprogrammed. Could this be the case?
Also I've tried this on 2 Windows PC's and 1 Linux PC. Same result everywhere.
On windows, the board in the device manager isn't recognised as "Arduino Uno" like i've seen on screenshot's of other people online. Instead it is recognized as "atmega16u2" under 'other devices'. I think this also might be an indication that my board came unprogrammed. When I try to install the driver for the atmega16u2 device , i point to the correct Driver folder supplied by Arduino, the ArduinoUno.INF file is there, but windows says it can't find a driver in that location...
On Linux i don't see anything listed (but i'm still a Linux Noob)
Tonight I'm gonna try the board on a MAC.
This is quite demotivating, and i'm now left wondering if i'm doing something wrong or it it might be the board itself, so any help or info is greatly appreciated!

Hmm just found this in the troubleshoot: "Make sure there's a bootloader burned on your Arduino board. To check, reset the board. The built-in L LED (which is connected to pin 13) should blink. If it doesn't, there may not be a bootloader on your board. "
In my case the L LED comes on and stay's on...
Do I need hardware to try and fix this? Or should I just ask the shop for a replacement?

Kind Regards


Do I need hardware to try and fix this? Or should I just ask the shop for a replacement?

I would ask the shop for a replacement if that is possible. The board should blink it's pin 13 led on initial power up. Often (but not always) the board will come with the blink sketch already uploaded to it so the after the short blink it will start the one second on and one second off blinking that the blink sketch does. Where did you buy the board? Is there a link to the store?



Hi Lefty,

Thanks for the fast reply.
I've bought it at www.iprototype.be
They are an offical reseller listed on : http://arduino.cc/en/Main/Buy
I'm pretty sure it's an offical UNO REV3.

But i've also read about using FLIP to fix the bootloader, do I need any hardware for this?
If not, I'm willing to try to fix it. I've bought the Arduino to learn, and these types of issues are very annoying but it's also very rewarding if you can fix it.

Coding Badly

Before mucking with bootloaders and other low-level things a sanity check is in order.  Did you follow the instructions here...


Jan 08, 2013, 11:02 am Last Edit: Jan 08, 2013, 11:05 am by memorex Reason: 1
Hi Coding Badly,

Yes, i've followed the instuctions to the point I was able.
I did this :
-Download the software
-Plug in Arduino UNO ==> Power led goes on (green), L LED (yellow, close to pin 13) goes on but doesn't blink at all, it goes on and remains on as long as the board is plugged in.
-Device Manager lists it as under "Other device" instead of "Ports (COM & LPT)" and it is called "atmega16u2". When I try to install the driver and point to the correct folder. Windows says it can't find the driver.
-I despite tried to use the IDE to upload the blink program, but the serial port known to the IDE remains there even if I uplug the arduino. So it's not the right one...

Linux doesn't even seem to recognize an USB device was added (but i'm not familiar with these kind of things under Linux so i'm not sure...) and the drivers of my Linux machine might be a mess...

Before messing with the bootloaders, and the FLIP thing. When I leave work today, i'm taking it to my dad's place to test it on a iMac and see what happens...

Thanks for trying to help!
Kind Regards

Louis Davis

Since the Device Manager is showing "atmega16u2", your Arduino is in DFU mode.
This indicates the atmega16u2 does not have the Serial to USB code loaded on it.

If you want to try to recover it yourself you can use the following page as a guide.

The instructions are the same for the 16u2.
Since you are on Windows, you can download and install FLIP. (The link is on the page above)

Download the following firmware and install this on the 16u2 with FLIP:

After that, you should be able to install the UNO USB serial drivers.

Hopefully, the bootloader is installed on the atmega328.


Jan 08, 2013, 07:43 pm Last Edit: Jan 08, 2013, 08:16 pm by memorex Reason: 1
Hi Louis,

First of all, I would like to make it clear, the Arduino behaved like this out of the box.
I just now flashed my atmega16u2  with the hex code you mentioned.
First I had to install the driver for it (which is in a folder in the install path of the FLIP program)
Then I was able to use FLIP to write the program.
Unplugged it, plugged it back in. (The L LED still doesn't blink, it's still ON all the time).
Tried to install the Arduino drivers, and this time it worked.
Now the Arduino lists under COM ports as Arduino UNO(COM3) .
I started up the IDE, opened the Blink.ino file, selected COM3 as port and Arduino UNO as board.
Pressed upload,  and now I get another error :
"avrdude: stk500_getsync(): not in sync: resp=0x00"

While uploading the RX led flashed, But the L led is still on, and the TX led doesn't do anything.
Found a thread on this subject :
But nothing suggested in the thread worked, I get the same 'advanced output' as in the thread.

So yeah, I think mine came with both chips unprogrammed. Manged to 'fix' the atmega16u2 but I have no device to burn the bootloader onto the main chip. I have ordered a second Arduino Uno from another site. I read i could use a working arduino to burn the bootloader on another one. If the guys at Iprototype can't help me out, I'm gonna try to fix it with another Arduino. :)

Thanks everybody for trying to help, now I'm gonna ask Iprototype what to do.


We're a reseller and have had a couple of boards returned with this problem. The fix in most instances is to reseat the ATMega as in push it down firmly into the socket. Also fixes a number of intermittent problems!



I have the same problem with my uno rev3 as you phenoptix.

I also tried to flash the 16u2 chip with the firmware postet by Louis Davis.
The upload worked.

Then I got the same error message "avrdude: stk500_getsync(): not in sync: resp=0x00"

I have a second arduino uno rev1.
I installed the bootloader to the rev3 328P with my rev1 arduino - worked.
But I still have this error message.
I plugged my new 328P to my old board - worked.
I can upload sketches as known.

I think the problem is that the firmware of the 16u2 don't work properly.
Can you help me in this case?


Hi, i've the same problem..
I understood that the problem is inside the ATmega16u2 Bootloader not on the Firmware..
I've a normal Arduino UNO and an unprogrammed Arduino UNO (bought from ebay)..
I flashed the bootloader on the 328P moving the chip on the working board, and with that is possible to flash the sketches on both the 328P successfully..
I flashed then with Flip the https://github.com/arduino/Arduino/blob/master/hardware/arduino/firmwares/atmegaxxu2/arduino-usbserial/Arduino-usbserial-atmega16u2-Uno-Rev3.hex file and rebooting the Arduino board, Windows detect Arduino UNO instead of ATmega16u2.. but when i try to download a sketch, i got always the same error message "avrdude: stk500_getsync(): not in sync: resp=0x00".
The only difference on the 2 different ATmega16u2 is the bootloader.. The working one has the version 1.2.0 and the other one the 1.0.0..
Is possible in some way upload the bootloader (from the EEPROM) from an ATmega16u2 and download it on another one?


We're a reseller and have had a couple of boards returned with this problem. The fix in most instances is to reseat the ATMega as in push it down firmly into the socket. Also fixes a number of intermittent problems!

After all these years, arduino boards are aliens aliens to me!! This actually solved my problem  :smiley-eek-blue:

Let me just add my timeline:

Bought a new Arduino UNO R3 for the first time.
Plugged in the USB cable. Power LED (green) on. L LED blinking... So far so good...
Add problems with drivers, solved... Serial ports, ok...
Tried to upload a simple example... ... ... avrdude: stk500_getsync(): not in sync: resp=0x00
Tried again but this time looking at the RX and TX LEDs, RX blinked only once and..... nothing else... event the L LED died or stayed on... (what the hell)
Tried everything in my book and forums... Solution: Take out the ATMEGA and put it in again

Go Up