Go Down

Topic: Uno R3 connection error (Read 1 time) previous topic - next topic


Jan 08, 2013, 03:11 am Last Edit: Jan 08, 2013, 03:43 am by powerguy Reason: 1
While uploading a program to the board, the computer I was using turned off with out warning, it did not shut down, it just seemed to die. When I turned the computer on, it did not recognize the Arduino. I then tried on a different computer, and I got the same message when I plugged it in, something like, "Windows does not recognize your USB device which has malfunctioned ..." I have tried uninstalling the device with the device manager and then re-installing the drivers, but I keep on getting the same message. The Arduino still works, the program that was on it still runs, but I can not connect it to my computer. Does anybody have an idea of what is wrong?
EDIT: the message I get when I plug it in is "One of the devices attached to this computer has malfunctioned, and Windows does not recognize it.


Which Windows and Arduino IDE versions are you using?


Sounds like your board may have developed a short circuit on it somewhere causing too much USB power to be attempted to be pulled from the PC when you plug it in, so it yells at you to stop doing that.  ;)



Thanks, I am using Windows 7 and Arduino IDE 1.03 if that helps.  If it is a short circuit, is it repairable? Right now I can't see anything that might cause a short.


Now I have done a loopback test, which failed, probably because the correct com port does not show up.

Go Up