Go Down

Topic: Can't view serial monitor window (anymore...) (Read 8399 times) previous topic - next topic

Samfarmer

I just updated Java to version 7 and I can no longer see/view the serial monitor window.  The serial monitor itself opens and begins communicating with my board, but I can't view it.  In my windows task bar I can see the "mini window" and I see it running the sketch.  The TX light on my micro lights up once I open the serial monitor.  In the small task bar window I can see the serial monitor updating every second as its supposed to (patiently waiting for me to input the unix time). 

I'm running Windows 7, Arduino 1.0.3, using a Micro board, and have a RTC connected.  I tried uninstalling Java 7 and reverting back to Java 6 to no avail....  I tried searching for people having similar issues and couldn't find anything. 

This is driving me crazy!  Any help would be greatly appreciated!!!

Coding Badly


Open a command shell.  Run[font=Courier New] SET [/font](no arguments).  Any Java environment variables defined (like[font=Courier New] JAVA_HOME [/font]or[font=Courier New] CLASSPATH[/font])?

Samfarmer

Thank you very much for the response.  I inadvertently figured it out... still have no idea what was happening, but its working now.

Thanks again! 

ghosthawke

I've got this problem too!  What's the fix???? Thanks

ivankrishna

i got this too. what should i do?
i didn't understand with the way on replied #1.

i hope there is another way, to solve this problem. Thanks

mithunmohann

It is likely that it is running in the background. If you are working in Windows Operating Sytem, open Task Manager -> 'Applications' tab and right click on the Serial Monitor window instance and select "Bring to Front" option.

ej908

#6
Jul 18, 2015, 12:03 pm Last Edit: Jul 19, 2015, 05:15 am by ej908
*****SOLUTION*****
I finally found the solution for this problem.
I was having this problem for a while too and it was bugging me. It is actually quite simple.

1. Open Arduino
2. Click the serial monitor. (Of course you need to have the arduino plugged in and on the correct port)
3. Press "Windows Key+P" to open up the projector settings.
4. Change it to "extend".
5. Then change it back to "PC screen only"
6. You should be able to see the serial monitor now.

That should fix it. As I said it is pretty simple.

- Ej

thebear132

Hey guys!

I just found a solution. I had the same problem and i couldnt figure out how to fix it.
I started the Task Manager / Job List, i found the "Java (TM) Platform SE Binary" almost in the top. I unfolded it and right-clicked the one with my COM in it. Eg. COM3 (Arduino/Genuino Uno). And clicked "maximize". And then i could see it!

-TheBear

Andyf27

Thank you thebear132 -this solution worked perfectly for me!

Govner



I know this works in XP and perhaps other versions. I had the problem that when minimized, the Serial Window disappeared completely but as one person said, when they MAXIMIZED the window, the monitor became visible.

The problem arose after changing video monitor settings, adding a new monitor, regardless of dual/single monitor configurations. It was the changing of the various resolutions that caused the issue. It was discovered that, in reality, the "minimized window" is simply out of the viewing area. Don't ask me how/why Windows get confused about the desktop sizing but it does. To get it back, verify that you do have a serial monitor active. Look down in the task bar and you should see the Arduino logo for each window that is being used. The serial monitor simply has "COM15" (for example). RIGHT-CLICK on this and you'll see the window options (MOVE, SIZE, MINIMIZE, MAXIMIZE, and CLOSE). Select MINIMIZE. When you do, and the problem exists, the MAXIMIZED window disappears and, poof!,  no more serial monitor. It's simply out of the desktop viewing area. Now, RIGHT-CLICK the COM15 window (down in the task bar) again to bring up the MOVE, SIZE, etc menu as before. This time click ONCE on MOVE. You will see the cursor change to the 'directional' cursor. DON'T click or do but one thing: PRESS AND HOLD down the SHIFT key. This allows you to now use the ARROW keys to move the window. In my case, my Serial Window was about 10 feet off the left side (exaggeration), you get my meaning.  Once I moved it back into view, happy days.  I just about pulled all my hair out on this for a couple days.  Good luck.  (Sorry I don't have time to proof read this, or compress the language either. )

Go Up