Go Down

Topic: Using android mobile to control arduino (Read 233277 times) previous topic - next topic


I have a senior project , our instructor couldnt help me , because he siad that arduino and android isnt his domain, and said that it a new tech ,go ask some experts,, so i made plenty of searches but rarely i got info :(
in my project i need to control ( turn on and off lights using arduino,  android mobile phone , via bluetooth )
i bought an arduino uno , arduino shield (for Bbee ) , bluetoothbee, and relay...
i saw ur codes , but i need u to tell me where to use them  .. plz help me if u can..
ive downloaded books but sooo many codes....
MY problem is that in our country we have no experts in arduino, neither android programs..
i tryed to download from speedy share as u suggested , but it was denied , they asked for premium......
can u help , and be an advisor for this project which i couldnt have  , plzzz


You have to copy and paste arduino code into arduino IDE and then upload it to the board

You're right about speedyshare - you can no longer download the files for free
I'll try to upload them somewhere else


thank u ive downloaded the files , but i couldnt copy them to arduino ide,, it didnt open ,, do u have a way to open those files ,, ar any program to open them ???


i have a bluetooth bee iteadstudio ,, but ive seen some codes from seeedstudio for my bluetooth, is it the same ???
i tryed but it didnt work !
how can i try it ??


the code for arduino uve prviosly wrote in the first page about pin 7 coudnt be uploaded to arduino ,, problem is because of COM .. but only 3 COMs  4, 5, 7  also didnt work , access is denied ..
whats the problem?? i am using arduino 1.5.2


First of all you can't have the bluetooth module connected to RX and TX when you upload code - upload code and then connect them.

Secondly, the module you have might be set to different default baud rate - you either have to change it (using AT commands) or modify arduino code to use the module default baud rate.

What's more, make sure that the module is set as master. The datasheet should have some information on that.

Finally, use a USB bluetooth dongle and program such as Putty to try to establish connection with the module and android device. In this way you can manually send and receive commands and see if the module and/or android device works as expected.


i uploaded the code it worked ..
as for comunication with bluetooth it didnt happen , i tryed to comunicate with bluetooth by serial monitor .. it didnt work , as for Putty i tryed it it also didnt comunicate , i tryed AT and +++ ,, waiting for an OK .. also nothing happen ..
what baud rate , and com do ITEADSTUDIO bluetooth bee work ????..
kerimil am realy thankful for ur concern :)


Did you try to establish connection between the phone (app) and a computer to see if it works ?? it should work just fine.

i tryed to comunicate with bluetooth by serial monitor .. it didnt work , as for Putty i tryed it it also didnt comunicate
even if the baud rate is wrong you still get something on the other side - just a bunch of characters that make no sense

There must be some other problem - I assume it's either wiring or slave/master setting

i tryed AT and +++ ,, waiting for an OK .. also nothing happen
All bluetooth modules that I've seen require you to send AT commands through FTDI adapter not directly through bluetooth SPP.

Not sure if that's the module you have but I found this ->

Also I found this thread that you might find useful -> http://arduino.cc/forum/index.php?topic=100008.0;wap2


thnk u , i only need ur source code for the application on android phone plzz .. i gues i figured out the problem ,, in the xbee shield its not suppoting a connection betwwen bluetooth rx , and arduinos tx...
so now its responding .. so plz give me ur app source code


The source file can be downloaded here -> https://drive.google.com/folderview?id=0B_PfPoEotOF8N2JwT3RSX011SjQ&usp=sharing

Note that source files have .ZIP extension. That's why you didn't notice it. I describe how to upload them in this video


those codes can be opened by what program... ??? i couldnt open them ..


it has to be uploaded (the entire zipped file) into app inventor

more on it here -> http://appinventor.mit.edu/


Can you please republish your mit app inventor application? the file no longer exists, I'm having troubles trying to emulate your application.

Go Up