Go Down

Topic: Arduino 1.0.3 Going crazy (Read 6060 times) previous topic - next topic

SurferTim


I know a little bit more by now... See this thread on the Ubuntu forum:

see: http://ubuntuforums.org/showthread.php?t=2118715

Still no idea what's going on but anyway...

I do. That thread has to do with the user group fail. My Ubuntu repository IDE install failed to add group dialout to my user, but that was a global kind of thing. It would affect all versions of the IDE.

sokopok

- I started that thread yesterday.
- I don't understand your reply: If you read the tread, you will notice that I am a member of the group dialout, and have been for years.
- Also in the thread: the ubuntu repo version doesn't work for me anymore (since I removed it a couple of days before), same results as with 1.0.3
- I can however use the tty directly to communicate with my arduinos (without using sudo): see http://playground.arduino.cc/Interfacing/LinuxTTY

SurferTim

One more time: Have you tried the Arduino website version?

sokopok

#18
Feb 23, 2013, 12:44 pm Last Edit: Feb 23, 2013, 12:47 pm by sokopok Reason: 1
Yes, of course I did.

ubuntu repo: arduino-1.0.0
website: arduino 1.0.3
beta: arduino: 1.5 beta

none of them work for me anymore.

I understand that this a very weird problem, but just search google: I'm not the only one have this kind of problems. I'm not pointing any fingers, I just want to get this resolved.

SurferTim

I don't know what to tell you. It took a few minutes to get my 12.04 box running. I just downloaded (again) IDE v1.0.3, and it seems to work fine. Is there something I should do after compiling and uploading a sketch?

There is one weird thing. The menu is very hard to read. There is not enough contrast unless you roll your cursor across them.

Erdin

I you are sinking in the swamp, you should get out of there right now.

Other computer, other operating system, new installation, whatever it takes.
Once you have it running on a different computer, perhaps with Windows, you could try installing Ubuntu on that computer, or using a USB stick with Ubuntu.

The link to the thread of the Arduino only working as root is from 2008. And I think I can remember I had to run Arduino as root a few years ago. So please forget that.

sokopok

Quote
I you are sinking in the swamp, you should get out of there right now.


I know! That's exactly what I'll do. For now sudo should do the trick, but I want to minimize using sudo as much as possible.
I'll reinstall Ubuntu and see where that gets me (Windows is just too horrible an OS, so there is no way I'm going there). I just need to do this carefully, making sure not to screw up settings and files from other apps... It's just, I was hoping to be able to circumvent this...


Go Up