Go Down

Topic: Another Arduino UNO driver issue (Read 1 time) previous topic - next topic

chi239

Hello there,

I am facing a somewhat similar problem with the driver installation for my Arduino Uno. As per the Arduino installation instructions, I should see "Arduino (COMxx)" under the Ports (COM & LPT) in Device Manager. But I do not see this. The Arduino Uno is, however listed under "Other devices." If I right click here and choose the "Install driver" option I can manually browse it till the unzipped "driver" folder, but the "ArduinoUNO.inf" file does not show up.

I know that the "ArduinoUNO.inf" file is definitely there as I can see it if I open the folder manually!

I have tried this with both the 1.0.3 as well as the 0023 versions, but with the same results. BTW, I am using Windows 7.

Can someone help me with this......THANKS!

Louis Davis

Steps to install the Arduino drivers in Windows:

Right click the Unknown Device in Device Manager
Select Update Driver Software
Select Browse my computer for software
Click Browse button
Select the Drivers folder under the location of your Arduino software installation. (Do not select the FTDI folder inside the Drivers folder)
Click OK
Click Next

VdubsNHacks

I was having the very same issue wherein every time I would rt click My Computer (Win7 x64) and go to manage, device management, rt click on the unknown device(yellow exclamation) and try to manually install drivers from the folder I had just unzipped etc., I would receive an error. 
I have another Arduino book, so I thought I'd see if the instructions on the installation of the drivers was any different.  This book, "Beginning Arduino" by Michael McRoberts(gotta give proper cred here)  said to go to control panel, System and Security, then Device Manager, then rt click on the unknown device and then rt click and manually install the drivers from aforementioned folder.  It also said when you get the message that "Windows can't verify the publisher of this driver software.", to click "install this driver software anyway".  Though I have no idea why, and I find it interesting that I never even got that message before, this simple little change in the navigation to the folder was what did the trick.  I was becoming extremely frustrated, and still don't know why the method i was using didn't work when I was essentially doing the same thing.  At this point, I am just happy i can actually move on to "playing" with the Arduino.  I hope this helps anyone else having these driver issues, because I feel your pain. Good luck. 

chi239

Hello Louis,

I tried what you said and........it works!

Thanks a million, mate!

Regards.

Go Up