Go Down

Topic: Nuovi sviluppi IDE 1.8.x (Read 414133 times) previous topic - next topic

gpb01

#2115
Feb 22, 2018, 03:44 pm Last Edit: Feb 22, 2018, 03:45 pm by gpb01
Qualcuno che ha Win 10 PRO potrebbe gentilmente provare ad avviare l'IDE mantenendo scollegata la board Arduino per vedere se fa la stessa cosa; è stranissimo comunque, secondo me è un problema di Java.
... come sai lavoro su macOS, ma ... in un angoletto, ho anche un PC Win 10 Pro (dato che alcuni programmi che uso, purtroppo, esistono solo su tale piattaforma) e ... MAI avuto problemi con nessuna versione dell'IDE che apro sempre SENZA alcuna board collegata.

Credo anche io che il tuo problema sia legato a Java o a qualche peremesso che è saltato ...
... hai provato con una installazione "portable" (quindi sandboxed) ?

Guglielmo
Search is Your friend ... or I am Your enemy !

menniti

#2116
Feb 22, 2018, 03:51 pm Last Edit: Feb 22, 2018, 04:15 pm by menniti
Anche secondo me, come scrivevo su, provo a fare una ricerca sull'internazionale, vediamo se ne esce qualcosa. ora provo a capire come si fa questa installazione portable e che vantaggi/svantaggi ci sono rispetto alla standard.

EDIT: mi sa che ho già le installazioni portable, visto che ho l'omonima cartella presente.

EDIT2: ho risolto semplicemente scaricando la versione zip e sovrascrivendo la precedente, chissà cosa si era danneggiato, ora vorrei fare la stessa cosa con la 1.6.7 di cui per il momento non vorrei privarmi.
Manuale "Arduino e le tecniche di programmazione dei microcontrollori ATMEL"
http://www.michelemenniti.it/manuale_di_programmazione.html
http://www.michelemenniti.it/offerta.html
Articoli ElettronicaIN
http://www.michelemenniti.it/elettronica_in.html

paulus1969

#2117
Feb 24, 2018, 08:57 am Last Edit: Feb 24, 2018, 08:58 am by paulus1969
Due diversi PC con Win10Pro, sia portable che normale.... l'unico inconveniente che trovo è una certa lentezza nella compilazione.

EDIT
Uso sempre l'ultima versione stabile ma anche qualche night build portable

nid69ita

#2118
Mar 08, 2018, 11:12 am Last Edit: Mar 08, 2018, 11:14 am by nid69ita
Segnalo che aggiornando il core alla 1.6.21 (Arduino Avr boards da "schede") per alcune Nano cinesi bisogna selezionare "Atmega 328P (old bootloader)" per fare upload. Oppure aggiornargli il bootloader. Qui una discussione: link
my name is IGOR, not AIGOR

PaoloP

#2119
Mar 08, 2018, 12:57 pm Last Edit: Mar 08, 2018, 04:21 pm by PaoloP
Qui la patch su github fatta per risolvere un problema di riavvio col watchdog attivo.
Secondo me il nuovo firmware non doveva essere messo come default.

gpb01

#2120
Mar 08, 2018, 01:19 pm Last Edit: Mar 08, 2018, 01:19 pm by gpb01
Qui la patch su github fatta per risolvere un problema di riavvio col watchdog attivo.
Si, era un problema noto con il vecchio bootloader su tutte le scheda (io lo ebbi sulle Pro Mini) ... Optiboot lo risolve.

Guglielmo
Search is Your friend ... or I am Your enemy !

nid69ita

Versione IDE 1.8.5 PORTABLE (quindi con cartella portable)
Ho aggiornato il core alla 1.6.207  (era la 1.6.206)

In questa modalità le schede sono sotto portable/packages
Ma per gli avr c'e' comunque sempre una cartella hardware\arduino   fuori dalla portable, e li dentro c'e' un boards.txt

Strananezza: installanto nuovo core, sotto portable\packages\arduino\hardware\avr\1.6.207
c'e' il boards.txt       quindi per togliere le boards che non mi interessano ho agito su questo file. 
Ma non lo ha considerato. Ho agito allora su boards.txt sotto  hardware\arduino    e funziona.
Peccato però che il file boards.txt di quella cartella ha data vecchia, quindi credo non sia aggiornato dal nuovo install.
Qualcuno ha IDE portable con core 1.6.206  ?   Dove stà boards.txt ?  
my name is IGOR, not AIGOR

zoomx

Ho appena controllato e sebbene io abbia una versione più vecchia del core, il board.txt sta in entrambe le cartelle che hai menzionato e, come da te, quella sotto hardware/arduino è più vecchia.

nid69ita

#2123
Apr 22, 2018, 10:46 pm Last Edit: Apr 22, 2018, 10:47 pm by nid69ita
Ho appena controllato e sebbene io abbia una versione più vecchia del core, il board.txt sta in entrambe le cartelle che hai menzionato e, come da te, quella sotto hardware/arduino è più vecchia.
Prova a rinominare quella che non è sotto packages, se compili a me dice che è mancante board.txt.
Quindi mi pare prenda quella fuori e secondo me è un grosso errore.
my name is IGOR, not AIGOR

zoomx

#2124
Apr 23, 2018, 09:35 am Last Edit: Apr 23, 2018, 09:43 am by zoomx
Ho zippato il boartds.txt presente in hardware/arduino/avr e poi l'ho cancellato.
Ho lanciato l'ide e non ho avuto errori.
Ho preso uno sketch e me lo ha compilato senza errori.

Però il mio core è più vecchio del tuo (1.6.21) ma a suo tempo è stato aggiornato usando il board manager.

Edit:
ho lanciato il gestore delle librerie e l'errore stavolta appare!
Code: [Select]
Could not find boards.txt in D:\IDE\arduino\hardware\arduino\avr. Is it pre-1.5?
WARNING: Error loading hardware folder D:\IDE\arduino\hardware\arduino
  No valid hardware definitions found in folder arduino.


A questo punto ho provato il board manager e invece l'errore non appare.

Contrordine:
Chiudo l'IDE, lo riapro, lancio il board manager e l'errore appare.

nid69ita

#2125
Apr 23, 2018, 03:42 pm Last Edit: Apr 23, 2018, 07:03 pm by nid69ita
Ho eliminato delle schede da quello sotto packages, lasciato file originale fuori, l'elenco è ridotto.
Pare gli serva la presenza di board.txt fuori da packages, ma poi non lo usa. Pare.

Mi veniva il dubbio che la gestione "aggiornamento Schede" per le avr non tiene conto del portable
Però il verbose compilazione riporta:
Code: [Select]
Using board 'uno' from platform in folder: D:\Elettronica\Arduino\arduino-IDE\portable\packages\arduino\hardware\avr\1.6.21
Using core 'arduino' from platform in folder: D:\Elettronica\Arduino\arduino-IDE\portable\packages\arduino\hardware\avr\1.6.21

Quindi cartelle sotto portable

Inoltre, mi sono accorto ora, a casa ho 1.8.5 portable e core 1.6.207 (e non mi segnala altro)
In ufficio la 1.8.5 portable e core... 1.6.21     ma a casa questa .21 non me la segnala !?!

Allego immagine di Arduino IDE di casa, combo versioni:
1.6.207 installed
1.6.206 prec
1.6.205
1.6.200
1.6.21         ?? boh non capisco
my name is IGOR, not AIGOR

zoomx

La 1.6.21  è l'ultima che si può installare con il board manager, 207 sarà forse una versione avanzata rispetto alla .20 ma inferiore alla .21.
Su GitHub la 1.6.21 sembra l'ultima a parte quella con IDE 1.9.x

speedyant

Mi fate venire un dubbio... Verifico le mie versioni portable.

speedyant

Ho appena controllato su una hourly 1.8.6 del 19/04/2018. Nel gestore schede mi trova come "aggiornata" la 1.6.21

PaoloP

#2129
Apr 24, 2018, 12:08 pm Last Edit: Apr 24, 2018, 12:09 pm by PaoloP
La 1.6.207 è una versione beta col supporto del 328PB. Se non avete quel microcontrollore non serve installarla.
L'ultima ufficiale è la 1.6.21.
Se via appare la 207 è perché avete aggiunto queste schede --> https://downloads.arduino.cc/packages/package_avr_3.6.0_index.json

Go Up