Go Down

Topic: Non-responsive Uno R3 (Read 701 times) previous topic - next topic

akarls87

Hi guys,

Today I noticed that my Uno didn't work as supposed, there is a basic sketch on it - reading some digital inputs and setting/resetting some outputs. When running I noticed that the outputs never got set. Connected the board to the computer (Win7) and tried to do some troubleshooting but now I couldn't get the computer to connect to the board. The computer says "Unknown device connected to the computer", I've tried to uninstall the drivers and re-install them but when the installation finishes I get "The software for this device was installed but may not work correctly. This device cannot start. (code 10)".

The "ON"-led is on, the voltages seem okay. I read somewhere that when you do a reset, the "L"-led is supposed to flash, it doesn't. The board has been connected to 12-13V supply, which is a bit higher than recommended but still okay I guess (limits between 6 and 20V).

Is there any way to check any signs of life on the board?
I do also have a Mega2560, is there any way to use that one to check the functionality?

regards Anton

spcomputing

You could check to see if the Atmega328 or the Atmega16u2 are talking.  First, get Nick Gammon's board programmer:
http://www.gammon.com.au/forum/?id=11635

Put it in your sketch folder and open the sketch up.  Go down to where the constants are defined and change:

Code: [Select]
const byte RESET = 53
const byte SCK = 52


Then Save as ABP_Mega or something else.  Upload to the Mega.  Of course, after upload, disconnect power.

Hook up Wires:

MEGA / UNO
5V   -   5V
GND - GND
D50  -  D12
D51  -  D11
D52  -  D13
D53  -  RESET

Plug in the Mega and open the serial window @115200 baud.

You should get output of the Atmega328 and all the fuses.  If that works, you will need to check the 16u2 from the ICSP header by the USB port (You could have done this as well for the Atmega328).  The pins are as such

Pin1 / Pin2 (Pin 1 is closest to the white dot or "1")
MISO - 5V
SCK  - MOSI
RST  - GND

or

D50 - 5V
D52 - D51
D53 - GND

Unfortunately, unlike the Atmega328 UNO bootloader included in the sketch, the 16u2 firmware is not included.  But, you can use your Mega as an Arduino programmer in avrdude and try to upload the firmware that comes with the Arduino IDE.

akarls87

Great instructions, thanks!

It seems that the 328 is dead, I only get

"Atmega chip programmer
Written by Nick Gammon"

on the serial display. I've ordered a new chip which I will try to get running instead.

Thanks again.

Go Up