Go Down

Topic: Problem with communication Arduino UNO on win 7 (Read 954 times) previous topic - next topic


Mar 26, 2013, 10:26 pm Last Edit: Mar 26, 2013, 11:19 pm by MadNutMat Reason: 1
Hi everyone!! I usually work with Ubuntu 12.10 on my laptop and everything works fine while trying to upload sketches on my Arudino UNO rev2. It happened i had to switch to win 7 to use arduino as serial port for debugging another project, and i need it to run while on win 7. In the start i managed to make it work properly (installing the right drivers on the right COM port). Then happened that Arduino IDE crashed, i restored the preferences files under C:\Users\xxx\AppData\Roaming\Arduino and the IDE works again....but the communication don't!!! The port in the IDE is the right one (the one windows installed as Arduino UNO), the arduino is the right one too....googled around but found nothing useful for my problem!!

EDIT : the IDE ends the upload with the famous "avrdude: stk500_getsync(): not in sync: resp=0x30"
EDIT2: i tried on another win 7 32-bit pc, same way to install the drivers and it works...don't really know what's going on...


That's annoying.  Have you tried to update the driver in the device manager?  If that does not work, I would un-install the Arduino and do a reboot to the PC.  This usually gets rid of any stupidity Windoze may have had before and you can re-install clean.

Go Up