Go Down

Topic: ROM-Reader for Super Nintendo / Super Famicom Game Cartridges (Read 356543 times) previous topic - next topic

gloworm17

I'm excited to build this.  I feel this is going to be great!  Does anyone know for sure that the GBA/GBC slot is correct on the needed parts page?  https://github.com/sanni/cartreader/wiki/Needed-Parts

It looks like it has the GBA notch thus rendering it unusable for GBC. Can anyone else confirm? Possibly offer an alternative?

sanni

Yes it's the correct part. Looks like this:



Both GB and GBA carts fit.

sanni

I wrote a little Sketch to calibrate the Clock Generator for the snesCIC.



https://www.dropbox.com/s/uyhpnng9zgfl2ja/clkcal.zip?dl=1

Usage: Upload Sketch, then connect SNES Pin 56(CIC Clock/CLK2) to SNES Pin 43(A18/Arduino D47) using some sort of wire.
The correction factor can then be put into SNES.ino and/or NP.ino: clockgen.init(SI5351_CRYSTAL_LOAD_8PF, 0, -16000);

dustytrash

Just got my PCBs today! Luckily ordered before the Coronovirus got too out of control.

I'm now noticing some pieces are not on the 'single cart part list', but only on the '10 cart list', such as the RBG LED, push buttons and 3 slide switches. Why is that?

sanni

The second sentence of the single cart reader parts list gives you all the small electronic parts you need to order. It's cheaper for a single cart reader build to buy the parts in lower quantity compared to the eBay and Aliexpress links for the 10 cart reader parts list.

Quote
Parts list for building a single Cart Reader

Total Cost: ~$51-$64 depending on access to a 3d printer

Electronic components:

Download this excel file and upload it to lcsc.com, then click on the blue add-to-cart button.
Total: $10 (new customers get a $4 coupon)

In case something is out of stock at LCSC you can have a look at the "Parts list for building 10 Cart Readers" below.
Source: Needed Parts

They offer a $15 coupon on shipping right now instead of the usual $4 or so but I can't find the terms to see if it has a minimum order quantity required.

gloworm17

Thanks for the clarification.  Do I need the SD Card 8+1 socket on LCSC if I'm getting the whole micro SD module from eBay?

Also, how does that (micro SD) affect the 3D printed parts?  Do I need to have "Combined_no_tabs" and "microsd_spacer" ?   Lastly, with the "Combined_no_tabs", I need all parts listed under screws?

Thanks for the innovation and help!

sanni

You won't need the SD card socket, good catch, I should remove it from the parts list.
You don't need "microsd_spacer" since the spacer included in "Combined_no_tabs" is universal and will also fit for microSD.
Yes you will need all the listed screws. There is probably a way to source them cheaper than eBay though.

Since the spacer in the Combined STL file will be printed in the same color as the rest it has a hole to let the light from the LED shine through:


The microSD spacer is supposed to be printed in clear and fits around the mSD module which gives a nice lighting effect:


Both spacers need to be fixed in place by either double-sided tape or some hot glue.

Yippikaye

Hi,
I have a cart reader from 2017 with a 3.0.0 version I think.
I tried to update it, I've followed the instructions, but I have this code error :
'SdFat' does not name a type; did you mean 'SdFat_h'?
Unfortunately I'm not able to go back to the previous version, the lcd does not power anymore :(
I'm stuck,


Yippikaye

I've went the route of another arduino program,

Now it works with your link, tested and everything is fine.

Thank you for the support  :smiley-lol:

LHCGreg

I'm having trouble dumping two of my famicom games, Akumajou Special: Boku Dracula-kun (Kid Dracula) and Wai Wai World 2. I'm using a Hyperkin 60 to 72 pin adapter with the NES to SNES adapter from the project. They both play in an NES using the adapter fine. All of my other famicom games dumped fine: Cocoron, Kaiketsu Yanchamaru 2, Nekketsu Street Basket, Splatterhouse: Wanpaku Graffiti, Sweet Home, Wing of Madoola, and Wai Wai World 1. I consistently get the same wrong dumps so I don't think the connectors are dirty, but I cleaned them anyway. Kid Dracula PRG CRC32 A3C34504, CHR CRC32 1168B730. Wai Wai World 2 PRG CRC32 27BDC42D, CHR CRC32 75754679 (CHR is actually correct). I assume these are indeed bad dumps and not unknown dumps because, after adding the nes 2.0 header, they both crash in Mesen and puNES with an illegal opcode before displaying anything.

Of note is that Kid Dracula is a VRC4 with mapper 23, Wai Wai World 2 is a VRC4 with mapper 21, and Wai Wai World 1, which I successfully dumped, is a VRC2 with mapper 23. Any ideas? Could there be something about VRC4 boards that isn't working with the famicom to NES adapter?

Bent82

Hi sanni, I bought an assembled reader from you several years ago, an older single slot model, before the current design.  I recently pulled it out, I had some SNES carts I wanted to dump, and turned it on for the first time in several years.  After inserting an SD card, it booted to the menu, it had version 19J of the sketch on it, which is quite old, so I wanted to update it before I used it.  I downloaded the latest sketch and uploaded it.  But now, every time I turn it on, I get an SD error.  I am unable to proceed past this screen.  I also tried the portable install that you provide in case there was something up with my installed libraries, same thing.  Any ideas?  I believe the old design is still compatible with the sketch, right?

sanni

In Cart_Reader.ino line 63 change:

Code: [Select]

// Enable the second button
#define enable_Button2


to:

Code: [Select]

// Enable the second button
//#define enable_Button2


Then upload again and see if it works now.

skaman

Mappers 21/23/25 are a mess (especially the VRC4 variants). 

Boku Dracula-kun was one of my original VRC4e test carts so it should work.

I'll have to recheck the Mapper 21 code for the handling of Wai Wai World 2.  I used Ganbare Goemon Gaiden 2 as my Mapper 21 test cart but it uses a different VRC4 variant.

I'm away from all of my cart reader stuff at the moment.  I'll retest the mappers when I'm able to.

Bent82

Code: [Select]

// Enable the second button
//#define enable_Button2


Then upload again and see if it works now.
That took care of it.  It also didn't like the large SD card I was using, but just a smaller one by itself without commenting out that line didn't work.  Thanks for your help!

Go Up