Go Down

Topic: ROM-Reader for Super Nintendo / Super Famicom Game Cartridges (Read 358075 times) previous topic - next topic

skaman

I redumped Boku Dracula-kun and the current code produces the proper dump.  My standalone Famicom reader dumped the cart without a problem.  It took a few tries using the FC-SNES adapter with sanni's Cart Reader.

I have a copy of Wai Wai World 2 on the way.  I'll check it once it arrives.

LHCGreg

I redumped Boku Dracula-kun and the current code produces the proper dump.  My standalone Famicom reader dumped the cart without a problem.  It took a few tries using the FC-SNES adapter with sanni's Cart Reader.

I have a copy of Wai Wai World 2 on the way.  I'll check it once it arrives.
Do you have a famicom to NES adapter, the kind used for playing famicom games on an NES? I wonder if that's causing my issues, maybe messing up the timing?

skaman

I tried reading Boku Dracula-kun using an official Nintendo FC-NES adapter (Gyromite) connected to the NES-SNES adapter.  The data is jumbled as the bankswitching is not working properly.

iraqfallujah

hello sanni
i have a question about your awesome cart reader.
i made eprom gameboy cartridge (27c256 use)
if i insert my 27c256 homebrew cartridge on cart reader(gba slot), can it flash/erase?

my question is your cart reader can read/flash/erase my eprom(27c256) flash cart?

sanni

No, 27c256 can't be programmed with the Cart Reader. Only 29F080/16/32/33 flashroms are implemented for Gameboy.

iraqfallujah

No, 27c256 can't be programmed with the Cart Reader. Only 29F080/16/32/33 flashroms are implemented for Gameboy.
oh i see. thank you for reply sanni

dragynfyre

I'm trying to read and write the save file from Conker's Bad Fur Day for N64 (16kb Eeprom). I have the switches set to the correct setting (3V and Eeprom). When I try to write the save file it finishes the write quickly but then gets stuck on verifying the save. The LED also stops lighting up. When I read the save it gets stuck on "Reading Eeprom...". I've left it overnight so its definitely not just being slow. I am using the serial monitor.

Any ideas on what the problem is?

sanni

Can you post a picture of the Conker PCB? Maybe it uses a different variant of the eeprom chip.
Do you have any other games with eeprom save that you could test like Donkey Kong, Perfect Dark, Starwars Racer?


dragynfyre

Actually I just tried Banjo-Kazooie (4kb eeprom) and Banjo-Tooie (16kb eeprom) and neither of them work. I know Banjo Kazooie worked back in May 2019. I'm gonna try reverting back to Version 3.1. Do I need to have the switches in any specific position while updating?

sanni

Switches don't matter for updating other than the On Switch being On.

There was a slight change to eeprom reading after 3.1 in the code. If 3.1 works and 4.X does not then you can revert that change by deleting line 2003 in N64.ino.



Also make sure the CLK1 switch is set to OFF when reading eeprom. Or else the clock will not reach the eeprom.

In case it also does not work with V3.1 here you can troubleshoot the hardware by checking the solder connections.
This is the path the clock line takes:


This is the path the data line takes:

dragynfyre

Looks like I need to take a look at the connections. Some observations

- V2.7, V3.1 and V4.6 all don't work
- Adding the line to V2.7 just makes the LED go dark whereas without the line it is blue. There's no blinking
- In V4.6 the LED blinks when writing the save to the cart but goes dark when verifying the written data. So I assume writing to eeprom may still work but reading it doesn't
- Reading the N64 ROM still works
- Reading flash memory still works (Paper Mario)
- I added some print statements and commented out noInterrupt and it looks like it gets stuck on the call to readData() so I assume this is a data line issue? Since the other functionality I mentioned above still works could it still be a clock issue?

Testing the data line connections I can see continuity between everything other than the middle pin of the eeprom switch and the GBA cart pin. When I test those points I see my multimeter go to 1400. The connection between the middle pin and the 1K resister is also fine as I hear a beep. So is the issue here likely to do with the connection between the switch and the data lines? I'm not sure if I should hear a beep or if it should go to 1400 between those connections.

sanni

It should beep(or show less than 1 Ohm) between the middle and upper pin of the EEP switch and between those two pins and the N64 slot data pin and the GBA AUD/IRQ pin and the Arduino pin (top row 11th pin from the left).
So the 1400 Ohm you're measuring between GBA and switch sounds like the issue. It could be a short circuit between the GBA pin and one of its neighboring GBA pins(=RST and GND) or the two outermost pins of the EEP switch's case(=GND) could be shorted to the upper of the 3 inner pins.

So I would probably measure all the pins against GND and see if there is a short.
Also, all of those pins measured against any of the VCC pins should have a 1K resistance.

Note: If you got an N64 controller you can test if it's the data line because the N64 controller does not use the clock line and does not need the EEP switch, it just needs the data line between Arduino pins and Contr Data pad.

dragynfyre

Looks like all the other connections are good and there's no other shorts. I soldered a wire between the middle pin of the EEP switch and the GBA AUD/IRQ pin and it's working again! Is this a reasonable fix or will it cause problems when I try to use it for GBA again?

Also thanks for the really helpful and fast responses!

sanni

That's a good fix. The PCB probably has a defect on that trace that leads to a higher than normal resistance and with the wire it is repaired.

Beatchef

Hello! well I ordered my PCBs for the main unit and SNES to NES so I'm locked in now xD

Would this be an okay substitute for the SNES cartridge slot? https://www.aliexpress.com/item/32828880226.html and 'color' 2? without the screw tabs either side. Reason I'm asking is I'm trying to get as many parts from the same store as possible (in this case Kingworld) as otherwise the shipping absolutely kills (currently up to $50 in shipping alone)

Thanks!

Go Up