Go Down

Topic: com port problem (Read 2733 times) previous topic - next topic


i m working on a project where i m using servos for motion. i tried several programmes on single n multiple servos. but today all of a sudden the servos arent rotating at all... they get stuck at 0 position.. when i connected a single servo to the arduino my lappy showed com port problem as though the windows is not accepting the servo or something.. when i disconnected the servo leaving only arduino being connected there was no com port problem :| 


How are you powering your servos?


codlink seems to be on the job. You cannot power servos directly from the Arduino
board 5V pin, even though some of the tutorials show it being done. Maybe 1 servo if
you're lucky, but that's still not a very good idea. Also, if running the Arduino off USB,
those ports certainly cannot provide enough current for operating servos.

So, get a separate power supply for the servos, 5-6 VDC.


ya thats true.. problem got solved....  :)

Go Up