Go Down

Topic: Welcome ArduinoDroid - Arduino IDE for Android (Read 94594 times) previous topic - next topic


I used ArduinoDroid on MXQ (Android TV BOX)  with no big problems.
The Android on MXQ is 4.4.2 so I used an older version version of ArduinoDroid (sob).

Using it I developped  an app  to control Arduino UNO board via USB from PHP (USPphpTunnel)
see it here https://github.com/msillano/USBphpTunnel

About Arduino console terminal: the only terminal app that worked with my Arduino board is
"Serial USB terminal" https://play.google.com/store/apps/details?id=de.kai_morich.serial_usb_terminal.



Does not reliably see/recognize genuine Arduino Uno under Nougat (7.1.2) Occasionally, the ArduinoDroid sees the Uno, and I can compile an unmodified blink and send it to the Uno.  It compiles and appears to download and sends messages that it was received.  Change the code by only a single digit (changing the delay from 1000 to 100, or 1 second to 0.1 second) also compiles and downloads, and gives no errors at all.  Everything APPEARS to work well, except the LED 13 continues with a flash of 1 second on, 1 second off.  Obviously, with Nougat, it fails to actually update the Uno.  I am using a Google Nexus 5x with Android 7.1.2 and a Genuine Arduino Uno.  Software author has been unresponsive so far, likely aware that Nougat is a problem.


Apr 19, 2017, 10:12 pm Last Edit: Apr 19, 2017, 10:14 pm by Ballscrewbob
Does anyone have the current app link for this (not blog) as the one in the initial post seems dead.


THIS is the current link
It may not be the answer you were looking for but its the one I am giving based on either experience, educated guess, google (who would have thunk it ! ) or the fact that you gave nothing to go with in the first place so I used my wonky crystal ball.


Hi, Arduino Droid is a great software, but I'm finding trouble uploading codes to my Arduino Uno. Sometimes it works just fine, but most of the times, the following error occurs =>

Uploading error

avrdude done. Thank you.

Error: Process returned not 0 result code: 1

How can I solve this problem.


Hello, I'm newbie in Arduino programming, but I try...

My problem...  I made a Outside Geocache for Geocaching Game, then I made, compile and upload my code to my Arduino UNO, but sometime I have to make some change in the code and the Geocache is already in the outside field, so I can't bring it back to home and plug it in my PC.

So I found Adruino Droid for my cell phone, I was happy to know I skould be able to make my change in the field, but the library I use in my code can't be install in my Arduino Droid because they dont have the Library.Properties file then I received error message and I can do nothing with the app.

I search in the library list but I can't found the one I need, then I should have to redo the coding and I'm not able to do that alone.

So is therre a method to bypass this type of error concerning the Library.Properties file by making one by myself then add it to the zip file.

I'll wait for your answer.  Thank you
Yves Sabourin
Laval, Qc, Canada
Geocaching Alias: TopGun-50


I have installed ArduinoDroid on my tablet, which is rooted.
Basic sketches I can upload, but when I try to include library(such as DHT), it can't find files(in this case, DHT.h).
Names of folders are only letters of english alphabet, no other characters.
Can someone help me with this? Thank you.


Bad app....   >:(

I have Arduino on my pc and my sketch work perfectly, now I have installed ArduinoDroid on my Galaxy S5 Neo, I installed all the library I need for my sketch ans when I open my sketch, a lot of errors appear and I can't compile it.

So why it works on Arduino PC and not on ArduinoDroid?

I had flush it from my mobile!
Yves Sabourin
Laval, Qc, Canada
Geocaching Alias: TopGun-50


Because its not from Arduino themselves.

In this case it might be better to direct questions to the developer on thier website

It may not be the answer you were looking for but its the one I am giving based on either experience, educated guess, google (who would have thunk it ! ) or the fact that you gave nothing to go with in the first place so I used my wonky crystal ball.


Hello, I am amateur and discover the world Arduino thanks to your share and thanks to you all for mutual assistance, seeing on Yout. a programming video from a smartphone This has motivated me a lot,

I wanted to use the Uno since an Android Tablet Asus Zenpad 10 compatible OTG USB 16GB internal memory.

I make cheese at home my objective was to build a digital thermostat to manage the temperature and humidity of the fridge but I join the family of compilation errors. My Uno is a Funduino clone that does not compile.

In the comments of the application (in French) a person says to have succeeded by installing the Pack Driver but does not give more detail. The problem is that I have ordered everything as a donkey :-)

instead of first understanding the system so I am stuck because I do not have a PC. After researches, as my Uno is a clone and can be the clone clones I was advised to use an FTDI converter for ease of compilation,

Of course the first tip is utility a PC even a Netbook or a tablet Windows but I wanted to use the Tablet Asus in my possession avoiding having to bought a new devices.

My question is, how found the Pack Driver to download on the tablet? Can the Ftdi converter module set the compiler error problem? I thank you in advance for your advice and information.


Re: Hello, then I have news that I wanted to share with the galleys "Error compilation" like me,

there is another application of Anton Smirnov named (ArduinoCommander) thanks to ArduinoCommander

I managed to compiled the sketch (demo blink) present in the application, then I put the Uno in factory setting

mode with the sketch (Firmata) also present in the application, there are 3 possibilities Blink demo led 13

Sketch Firmata I have not tried yet, one thing is clear now,

I can compiled from my tablet with ArduinoCommander even if I have not already saved code in my phonebook.

I would have preferred to use Arduinodroid I'm happy for the moment of the result :-) go courage one can be succeed,

to finish Great thanks to Anton Smirnov who shares his immense work, it is a genius of electronics, sorry for mistakes because I use a translator, cordially.


Hello since the beautiful France that starts to refresh, I wanted to share the end of my adventure, finally I managed to compile a skit, after changing my Asus Zenpadn10 against a Samsung Galaxy Tab. everything is in order

I can use my Uno clone and even those with chip CH340, so very expensive ANTON SMIRNOV you are a genius and the only real Arduino IDE Director on Android with "ArduinoDroid". When I figured out how to import the external libraries on the ArduinoDroid folder

I would buy the full app 2,99Eur is worth more as the work is huge, I do not know if you have time to read this message, Great respect a you Anton Smirnov I wish you happiness, Thank you.


This app works like a charm! For a scientific project I would like to create my own app interfacing an Arduiono Nano. I don't understand how to deal with USB Host permissions in Android 9. I would very much like to know how this app is dealing with the permissions.


Hi all

I do like arduinodroid even i new in this environment,  but when I try to compile sample or other projects using this library  Adafruit_ssd1306 always comes with error message : class 'Adafruit_SSD1306' does not any field named wireClk and restoreClk.
And when I look into file Adafruit_SSD1306.cpp there is in last line writes ;

#if ARDUINO >= 157
  uint32_t     wireClk;    // Wire speed for SSD1306 transfers
  uint32_t     restoreClk; // Wire speed following SSD1306 transfers

So I wondering what is wrong with this lines?
I try to compile on laptop with Arduino IDE 1.8.8 is just fine.
Please help how to pass through compiling with this kind of library.

Best regards



I nave problem with processi return not zero ,code result:1
How can i solve this problemi???


Jul 18, 2019, 04:32 pm Last Edit: Jul 18, 2019, 04:32 pm by jonisonvespa
Hi, wonder if this is any good and worth using ?
And does it actially work?

Go Up