Go Down

Topic: Serial port already in use (Windows 7) (Read 6868 times) previous topic - next topic

abcde13

You know what the title means, so here are the details

OS: Windows 7, 64-bit
Board: UNO
Issue: It says (for all ports I try) Serial port X is already in use, pleasequit any ...

I have downloaded the "enhanced version" some guys link to in other threads.
I have uninstalled and reinstalled the drivers, enabled and disabled
the com port, and restarted my computer

I have stopped services I think are scanning all USB ports, but I am not
sure how to see ALL the programs that are scanning all my ports.

Any tips?

padapolo

Hello,

I have the same problem with my leonado board.

I finally found a solution by checking the usage of the COM ports. In found that the windows manager does not display some hidden devices.

To see all the devices you have to :
- edit the environment variable DEVMGR_SHOW_NONPRESENT_DEVICES to the value of 1.
- then to open your device manager, pull down the View menu, and select Show Hidden Devices
I followed this explaination => http://www.istime.com/istdnn/Portals/0/Documents/Proc%20and%20Instru/Computers/Make%20COM%20ports%20available.pdf

When I did that I saw many arduino devices (in grey) and I deleted them.
It worked for me and so far I can use my arduino again normally.
My explaination is that I used my arduino board on all my differents USB ports (for each USB port used, it reserved 2 COM ports !).

I hope it will help you.

prathameshkakade

I tried according to your post,but still I am getting the same error.

mikeso51

Something else you could look at is the settings on the COM port connected to your Arduino.  If you look in the Ports file in Device Manager on your PC you can view the settings for the Arduino port.  I had a bus conflict problem on my set up which seems to have been caused by Flow Control being "Off".  I changed it to "Hardware" and the problem has gone.

HTH

Mike

prathameshkakade

No use.Already tried that.
Any other ideas?

warwound


Any other ideas?


Have a look here: https://sites.google.com/site/serialballpointmouse/.

I had this 'serial port in use' problem and it turned out to be this archaic Microsoft Serial Ball Point Mouse driver thinking my Arduino was a mouse each time i tried to use it.
Fixed by disabling the driver.

Martin.

Go Up