Go Down

Topic: Arduino Nano v3 power source autoselect (Read 1 time) previous topic - next topic


May 08, 2013, 04:21 am Last Edit: May 08, 2013, 04:56 am by 4ntoine Reason: 1
I have not original Arduino Nano v3 board (but it looks exactly as original one). When i try to use it with ArduinoDroid app on android and attach it to my Galaxy tab 2 with USB-OTG support i can see "High-powered USB device attached" android notification which means it takes more current that tablet can provide. In similar case with Uno r3 i just use external power source and it's fixed. But Nano v3 does not have external power source jacket and trying to use vin/gnd pins does not help - still see the same android notification so it makes me think it just don't use it and still tries to get current from usb from tablet.

I've tried to detach it from usb and it works (so it can use external power source) but when connected to tablet it still shows warning notification. i've also tried to use another android device with usb-otg support (xiaomi mi2) and the same result, so i think the problem is not in android device.

How can i fix it?

Go Up