Go Down

Topic: Due appears as COM6 port but gives error "No device found on COM6" on upload (Read 79678 times) previous topic - next topic


My experiences with my latest Due:

Problem: I cannot flash the due using the programming port UNLESS i press the erase button on the board first. I do not need to press the reset button, just the erase.
I'm using IDE 1.5.8. The board DOES reset on serial-monitor launch.

Resistances as requested R23 981R, R3 996R, R21 997R, R15 1003R, R14 1023R

Serial number D00045177. Received from SK Pang about Mid December.

Any known fix yet?


I've three arduino DUE boards and check all resistance on each, roughly R3 R14 R15 R21 and R23 have 1K value so I don't think the root cause is these resistance, there must be something else maybe a capacitor I suspect.

Why: all my 3 boards do have same resistance but only one does work when downloading a sketch.

In fact, sometimes it will upload ok, I'd estimate say 1 time it flashes CPU over 7 times ail it will not see the port of my MacBook Air.

The other problem to be honest, i've written Federico and no response, this thread has been lasting so the question being if arduino wants to solve the issue !

If downloading via native then it will work always



Hi all,

So I recently bought an Arduino DUE and I too have the same problem.
So far I've managed to upload my code 2 times: first after restarting my computer (I'm guessing this was luck because it worked only once...) and after holding the erase button for 2-3 seconds.

So I thought that maybe there is a problem with the ATMEGA16U2 not being able to erase the code from the SAM3X although it is supposed to do that.
I started looking at the schematics and the EAGLE board design and found a difference between the files and the actual board on the "erase"-path between the ATMEGA16U2 and the SAM3X. But I checked the way it is done on the board and it shouldn't be a problem but you might want to check it again.

I then started looking at the code that is supposed to be programmed on the ATMEGA16U2. But I'm not that good in C so I couldn't discover a lot. But according the piece of code shown here I think it is also supposed to work properly. (this code can be found in "Arduino\hardware\arduino\sam\firmwares\atmega16u2\arduino-usbserial\Arduino-usbserial.c")

Code: [Select]

if (ResetTimer > 0)
// --------------------------
// Between 60 and 120: do erase
if (ResetTimer >= 60 && ResetTimer <= 120) {
} else {

// Between 1 and 50: do reset
if (ResetTimer >= 1 && ResetTimer <= 50) {
} else {
} else {

I'm guessing now that the code loaded in the ATMEGA16U2 might be faulty for some of the boards but maybe that someone with a bit more understanding of C or the schematics could check my thoughts.


Hi all,

So I found a fix for the problem. At least for the version of the problem that I have.
As mentioned before, I could not upload a new code unless I first erase the old one manually even though the ATMEGA16U2 is supposed to do that.
When the chip receive the command of opening the usb communication at baudrate 1200 it is supposed to erase the old code on the SAM3X, but it doesn't.
I found out that when you spam the chip with requests to open the comport it will eventually erase the code on the SAM. So I wrote a batch file that does just that and that sends the new code after having requested 30 times to open the comport at baudrate 1200 and it worked in my case. I can now program my due whitout errors.
I know it's a very ugly fix but it works and might work for other people so if you want to give it a shot I can send you the code and how to implement it in the Arduino IDE.


I am having the same issue as well with my Arduino DUE. It has been working well for several months and all of a sudden it would not upload a sketch. Instead the IDE will say "No device found" on the COM port. This is despite the fact that the COM port is actually available in the ports menu option of the IDE. I am using the latest version 1.6.2

Only after pressing the "erase" button can I upload a sketch.

Just a thought. Could we all be experiencing the same problem because we have somehow damaged our Arduino Due? The I/O pins only take 3.3V. Maybe some stray static has caused this problem and "fried" the chip. A possible experiment would be to desolder the microcontroller and resolder a new chip on the board.

Yannouk could I please try your method of using the batch file to spam the Arduino by providing me with the code? Thanks.


Just bought my DUE from Robot Shop, made in Italy. Same problem and the fix of re-setting works.

I am using the native USB which is faster anyway. I found when you reset that the COM port changes - look on Device Manager! It only changes once  - for me from COM 16 to COM 15 and then it started working without the reset thing. So I am ok so far.


I just installed arduino-1.6.3 in my win8.1 buta I am been unable to comunicate with muy arduino due board. When I try to install Arduino Due Prog. Port windows don't find controller driver. I tried all drivers on FTDI USB Drivers and it doesn't work. Any idea please


Hi all,

" if you want to give it a shot I can send you the code and how to implement it in the Arduino IDE."
Pleaseeee Yannouk!!! Can you Send me the code?




I have the same problem with my 2 dues. I think no one find the exact solution. When I started to programming my dues, they were working good. However, a little later, they started to give the error "no device found on comxx port". When I plugged the due, the arduino ide recognizes the board. But, while uploading gives that error. Is there any way to test the problem on the board or the firmware on the chips. Any help will be appreciated. Thanks in advance.


I had the same problem that's been described here, I had a 1k Resistor in R23. I tried a few of these steps and found that the batch file was the easiest but unfortunately a working sample wasn't posted. Once again I did NOT modify or re-install any firmware. While I have hardware programmers I wanted a simple "Arduino" solution. What would the average Arduino Hobbyist have on hand. You will need to modify the COM port to whatever you use and I know there are other tweaks that I could make but once it worked I stopped. Have a great day!
Code: [Select]
@echo on
for /l %%x in (0,1,30) do (
mode COM4:12,n,8,1
echo > COM4


FYI to all of this thread that it appears that the problem discovered (and fixed) by emech in post #10 affects all of the R3 models of the Due.  I happen to have a number of R3 models and the mysterious R3-E models, and can confirm that all of my R3s will not power up and run, and all of my R3-Es will.  I also can confirm that the R3s all work correctly after applying the code fix from #10 and re-flashing the 16u2.  The details are here:


I will repeat the question here, since a number of people have asked, and noone has received an answer:



I have the Due R3-E model and it works fine with the Arduino IDE. There are no problems uploading my sketches. I switched now to Eclipse and installed this Arduino plugin from:
If I want to upload the code I get the error "No device found on COM6" but if I press erase on the board and try the upload again it works. What could have gone wrong by changing the IDE?



First, for anyone that has to unplug and then plug back in their boards, you can get a switched hub that turns the power lines off.  That means you can switch it off and then back on without pulling out the USB plug and thus reduce wear.  USB plugs/jacks will wear out eventually.

But where is this R23 talked about in this thread?  That is, where on the PC board exactly?  Can someone point it out?
Some of the resistors are very tiny and not marked.
Also, the schematic i downloaded shows R23 to be a 1k resistor already.

Go Up