Go Down

Topic: Due appears as COM6 port but gives error "No device found on COM6" on upload (Read 79709 times) previous topic - next topic


Federico asked "can you please measure the values of these resistors: R3,R14,R15,R21,R23? "

Here are the resistances from my Due board :
R14 1003 ohms
R15 998
R21 1000
R23 995
R3 985 Ohms


is your board affected by the uploading problem?
Because I see that the R23 is 1Kohm that is correct.



"is your board affected by the uploading problem?"

Yes. Sometimes the upload serial upload fails and usually it works correctly.

My Due works correctly in many sessions. I bought it at Newark in USA. When I start working on a Sketch the Due works perfectly. I edit then Sketch, plug in the serial cable, upload the instructions to Due, and it is good. I use the Due to test performance. I disconnect the serial cable. I run the Due successfully. I power down the Due. I plug in the serial cable and use the Serial Monitor to receive messages from Due. The messages are shown on my PC video screen as good text messages from Due. I power down. I need to disconnect my custom electronics from the Due using a DB25 connector to enable any uploads. If I keep the DB25 connected to Due from my experimental board, it never uploads, so I disconnect the DB25. I write a new sketch, I plug in the USB cable for upload. Failure ! "No device found on COM7"

I exit the IDE 1.52. I start IDE again. Failure. I disconnect the USB cable and start over to try to upload again. Failure. I power down my PC and boot up everything. It works now. Upload successful.

Sometimes Serial Monitor fails also. Then it works after re-booting computer. It seems intermittent. Re-booting is not alays needed, sometimes, just closing IDE and starting IDE makes serial monitor work.


I had been running my programs fine all day until I finally encountered this problem. This thread seemed to be the most helpful, but it seems like this has been going on for a while.
Since I'm relatively new to arduino, would it be better/easier if I seek a refund on my board?


I had been running my programs fine all day until I finally encountered this problem. This thread seemed to be the most helpful, but it seems like this has been going on for a while.
Since I'm relatively new to arduino, would it be better/easier if I seek a refund on my board?

If you have a clone board, it is situation normal, if you have a 'genuine' arduino board, I think you should try to PM Federico with date of purchase, serial number, and supplier you got your board from.

UTFT_SdRaw now included in library manager!! ;) High speed image drawing from SD card to UTFT displays for Mega & DUE.
UTFT_GHL - a VASTLY upgraded version of UTFT_CTE. Coming soon to a TFT near you! 8) Shipping April 1 2016!



You need to do three very simple things  after connecting the Programming port with the computer/laptop :
1. Press the erase button for about 3 seconds.
2.Press the reset button.
3. Upload the code.

You need to do this every time you want to upload a sketch. Everything else will hopefully work fine after that.

P.s : I think the problem is the board is not erasing the data pre-written or something.
And it is all done. Tried , tested , worked. Cheers !


Mar 10, 2014, 09:57 pm Last Edit: Mar 10, 2014, 10:04 pm by Josh_Transistor Reason: 1
I won't say this issue is solved. IT IS *NOT* SOLVED!
Using the Erase Button works but is not the solution to the originating problem.
Especially when debugging or trying things out it's annoying always to access the board itself.

I installed ATMel Studio with Arduino plugin - and from there it works without pressing the "Erase" Button on the Due Board and Resetting. Which is strange cause the Arduino plugin needs the location of the genuine Arduino IDE installation (in my case the latest Beta 1.5.6r2). When calling bossac from the command line it also DOESN'T detect the arduino port. The Arduino *Plugin* seems to do something different. Although i would suggest that the problem lies somewhere in bossac.

The DUE support doesn't seem to be very mature. And it's a strange version of bossac - which itself (the genuine one) has not been updated since a while, so it's a modificated version by the arduino team. I got none of them (neither the "genuine" nor the arduino one) to work.

I think the Arduino IDE with DUE support is called BETA for a reason.  Before r2 I had massively problems with the serial console - in contrast when using other terminal programs - which worked like a charm.
At least that seems to be fixed now.


Thought the power on reset might be fixed with a patch to the 16U2 (first thing that crossed my mind). Thanks. Would be nice if we could figure out why it is not working as it should without the patch, but at least we have a work around.



Same issue here. The board worked fine for several months but now it's completely unusable. I've tried the different techniques mentionned in this topic with no success. Resistors are 1K as expected. Serial number is D00036196.

Is there something else I can do ?


Hhmm, I've just found out that a jumper wire coming from my breadboard wasn't correctly connected to one of the ground pins of the due...  :smiley-red: Reconnecting it solved the problem. Why did that lead to the "No device found on COMx" error is beyond me, but I think it's worth mentionning it here.


hello, I have the same problem. The reference number is A000062. It works intermittently. Have you solved the problem?


I experience the device not found symptom too. It seems to only happen when my i2c is firing off.

The Reset + Erase hold works sometimes for me.


Hello, I'm having the same problem, here using a Macinstosh.

Please note that I've 3 DUE's, two of them work perfect when downloading a sketch, the 3rd one almost never downloads and writes "No device found on cu.usbmodem…."

Have this problem been solved since the failed DUE does have 1K resistor ?

Thank you keep an updated solution.


i have to use NATIVE PORT ,...................................................
programing port is  not workinggggggggg  :P

Go Up