Go Down

Topic: [HELP] Launch4j - An error occurred while starting the application. (Read 70122 times) previous topic - next topic


The only way I can get the new Arduino.exe to run is to Right Click and choose Run as Administrator.  Then it seems to function well.


per http://www.ultratechnet.com/2013/01/arduino-problem-invalid-window-handle.html

All you have to do is rename/delete(whatever you prefer) the "java" folder in the Arduino package and copy-paste the java runtime environment located in the program files folder. This is pretty simple hack which came to my mind while just trying to fix the problem. I hope this "technique" works with you.

Active Bluetooth device also seemed to be a probable cause for the problem, also responsible for slow behavior of the arduino IDE. Turn off the bluetooth device of your laptop, i.e disable the network and try again launching the application."

Worked for me.


I unintalled java and the bluetooth program and it fix the problem

I don't know why but I note that the problem begun when an update for java was installed, that is why I decided to uninstall java.



I am also seeing the same Launch4j error and it is happening on two different machines. I noticed that I only see it the first time I launch the Arduino IDE. Subsequent launches of the IDE do not give an error until I reboot, then I get an error again.

I just loaded version 1.5.4-r2 of the IDE. It asks for java permissions at launch. It does not give an error. I did nothing else to the java environment. It work on an old machine running xp and a windows 7 machine.

Do you get the same results?


Same Problem here.

Windows7 Professional x64
PC without BT

new install or deleting files not working


I'm W7 64bit.  I had the same problem using the Windows installer.

I uninstalled, downloaded the latest zip and unzipped to c:\arduino

I then followed the instructions


When I ran arduino.exe I was asked for java permissions and it all seems to work now.


Anti virus software can block Java, disable it temporarily.


Look for the Bluetooth icon in the right of the window taskbar.  Right click on it and click on turn OFF bluetooth adaptor. 8)


I'm having the same problem.  Tried all the tips and tricks in the forum but no luck. 
Args length:   272/32768 chars

I wrote about this headache on June the 16th and only one guy replied but lots and lots of peple must be having  this problem so Why on Earth cant some bod sort out this millais its and absolute scandle

On June the 16th I wrote:
Help is sought, if it is available.

Arduino IDE., starts: shows the usual Arduino blue panel; hangs for about 60 seconds then disappears leaving a warning box that states "An error occurred while starting the application".

I have been running the Arduino IDE., for some years now quite successfully until yesterday when my Windows system was updated. Unfortunately System Restore Protection was switched off and not by me.

Has anybody got the methodology and or knowledge to enable me to run this program please. Downloading a completely fresh system download has no effect, ie., it still will not run and provides the self same warning box.



Another Solution.

Arduino IDE decided to create a nested folder in C:\Users\cwcarver\Documents\Arduino. It created 2410 nested folders within the sub-folder "libraries". This prevented me from launching the Arduino IDE. I tried all of the other solutions provided, from reinstalling Java, reinstalling the IDE (both 1.0.5 to the latest nightly build), turning off Bluetooth, and unplugging my Arduino. Nothing seemed to fix the issue until I found the left over angst of Arduino creating 2410 nested folders. I am assuming Arduino took out it's anger on me for some unknown reason to create a recursive nightmare on my file system.

The problem is Windows cannot delete 2410 nested folders; even the SHIFT-DEL will not work.

There are two solutions; quick temp fix and solution.

Temp Fix:
Rename the C:\Users\cwcarver\Documents\Arduino folder to something else. I renamed mine to C:\Users\cwcarver\Documents\TOAST. This will allow the Arduino IDE to start normally.

Like I said, normal delete on Windows will not work. However there is a Windows command that is powerful enough to delete the nested folders; robocopy. Open up Command Prompt and type in these commands. Make sure to change the directories to fit your system.

cd C:\
mkdir Toast
robocopy C:\Toast C:\Users\cwcarver\Documents\Arduino /purge
rmdir Toast

The third command will take a long, long, so very long time to run. This is because robocopy is traversing all of the directories one by one and printing them to the screen. (For me it felt like 30 mins.) The command replicates the empty directory called Toast over the C:\Users\cwcarver\Documents\Arduino directory. Any differences found will be purged; aka deleted.

Once the commands are done, I could start my Arduino IDE with no problem.


i have same error.

if u have bluetooth .Turn off bluetooth and also rename the java folder in location C;/program file/arduino/
it will work definitely


Oct 03, 2014, 10:45 pm Last Edit: Oct 03, 2014, 10:48 pm by sachbearbeiter Reason: 1
I had the same error after updating java ->

launch4j - an error occured while starting the application

I deleted the C:\Users\USER\Documents\Arduino folder, afterwords i was able to start the arduino IDE.


I solved the issue deleting the infinites sub-directories under C:\Users\"user"\Documents\Arduino\libraries !

I think it's a scandal that the Arduino has still not fix this problem !

P.S: I deleted the infinites sub-dir with the "unlocker" (emptytool software)



Hi all, this is my first (but not least) post

I had the same broblem with WIN 7 arduino launch4j problem and i fixed it by doing some simple steps.
As you will notice, when the program starts and trying to run, you CPU lever will go up to 50% or more!
That's because the "infinite loop". Now do these steps exactly. (I have no responsibility so be carefull)

1) Open the task manager (alt+Ctrl+Del) from keyboard and choose "task manager"

2) Delete EVERY java* reference you will find there.

3) Now your CPU level must be under 10% which is OK

4) Open your C:\users\<your user name>\Appdata\Roaming\Arduino and make a backup of preferences.txt in a safe place and then DELETE IT

5) Now try to run arduino programm again and after succesfully enter, give again the appropriate settings.

Hope these steps helps. (At least they helped me!)

P.S. Don't forget to adjust your WIN 7 preferences to make Appdata dir accessible.


You may have a problem in your library folder,default path is
My Documents\Arduino\libraries\
cut and paste the libraries folder to My Documents so there is no longer a libraries folder in
My Documents\Arduino\
restart and see if that was the issue you can then copy the libraries back one by one to find the
problem library.

Go Up