Go Down

Topic: [HELP] Launch4j - An error occurred while starting the application. (Read 65727 times) previous topic - next topic

vimal_dubey

guys.. help... i have a project to complete.. this arduino doesn't start. i get "an error occurred while starting the application" launch 4j error.. i dunno what to do.. guys plz help... i tried everyfin possible...

jknutter

Just fixed my Launch4J error following some of the advice on this thread.  I was running 1.0.5 r2 without an issue on my main PC which is running Windows 7 64bit.  I've been bench testing a project called Ardomotic which is amazing.  I finally put Ardomotic to work.  I moved it from my test bench to a different network location and connected it to my server which runs server2003 32bit.  I installed 1.0.5-r2 on the server.  It installed and launched fine but when I tried to upload the Ardomotic libraries the IDE hung and I had to force it to close.  After which when I tried to launch IDE my processor would go to 70% running a file called javaw.exe and after about 40 seconds would give the Launch4J error.  I search every available forum and tried all of their tricks.  I removed the Arduino Application Data folder under user, reinstalled java, swapped the java file with my working computer, uninstalled Arduino IDE and reinstalled (about 10 times), cleaned the registry, blah blah and blah - everything I tried did not help...until today!  I discovered in my documents there is a folder called Arduino, in that folder there was a subfolder called Libraries - in that folder there was about 2000 subfolders all called Libraries nested off each other.  I could not delete or rename these as it generated a filename to long error.  I even tried using rmdir/s and del/s at the command prompt without success.  Finally I found a program called "Long Filename tool".  Unfortunately it found the nested folders but would not delete them unless I purchased a license for $29.  So after a little paypal action I deleted all of those library folders and IDE started right up.  It seems one of those libraries was corrupt and when it was uploaded screwed everything up.  I unzipped a fresh copy, uploaded them, and off we went.   

ulmis

#32
Feb 01, 2015, 05:25 pm Last Edit: Feb 01, 2015, 05:30 pm by ulmis Reason: a minor correction
Problem fixed!

Thanks to jknutter and others describing the "indefinete/libraries" -problem.

Before that I uninstalled arduino and java several times, no help.

But I had also a lot of nested "libraries" -directories in my Arduino library which I was not able to delete.

--- clip ---
Directory of  C:\Users\xxxxxulmisxxxx\Documents\Arduino\*

1.02.15  17:36         <DIR>    libraries
              bytes in 0 files and 1 dir

--- clip ---

When I renamed Arduino to ArduinoBroken, I managed to launch IDE again! (And a new Arduino directory was created.)




Now 2 questions

-what creates this looong chain of libraries?! A bug in Arduino somewhere but where? Anyway, this has happened to many of us... I am surprised that there are no other solutions to this.... IT WILL HAPPEN AGAIN TO SOMEONE

-how can we clean these broken directories safely without such tricky tools?  




chfakht

@jknutter :  in the subfolder Libraries , i have not found any subfolders called Libraries nested off each other.

SO  WHAT IS THE SOLUTION !!!

paul-y

I have been following this problem for some time now and have tried to fix it using some of the suggestions listed. NO LUCK !!

The problem for me is, I am not a computer guy. all I want to do is run my arduino IDE and play with some code. most of the fix's are beyond my computing skills.

This seems like a problem with the Arduino IDE code. so what are the people back at Arduino doing about it?

I have the Arduino IDE installed on two computers and they both have crashed. same problem "Launch4j error" what am I supposed to do? just throw away months of work and forget about it.

To me this is serious. please Arduino people, get with the program! "Pun intended" put this thing to rest once and for all.     

federicofissore


SarahN

I had similar problems. I think it came form the fact that my Arduino sketch folder was on a network drive. Putting the Arduino folder on C:\ seem to have solved the problem for now.

The problem was then to delete the nested folder (6000+ !!). Neither robocopy nor unblocker worked, but I finally managed to remove of all the junk folders using https://deepremove.codeplex.com/. Thought it might be useful to someone else.


paul-y

Well I was really hoping that someone from Arduino HQ. would jump in here and help us out but I guess not!

I went to the "DEEPREMOVE" sight but I could not figure it out. "thanks SarahN".

Yes "Federico" I am using 1.6.0 on Windows 8.1. it worked ok for a while then crashed. "launch4J error". also have 1.6.0 on another computer, windows 7 and it worked fine but started to slow down and eventually crashed. same problem. "Launch4J error"

How can there be so many different solutions to the same problem? is it possible there could be more than one problem that can cause a Launch4J error?

I am starting to get that sinking feeling..... looks like all my work is lost!

     

CrossRoads

Quote
looks like all my work is lost!
Why? Did you delete all your .ino files? If not, they are not lost.
Designing & building electrical circuits for over 25 years.  Screw Shield for Mega/Due/Uno,  Bobuino with ATMega1284P, & other '328P & '1284P creations & offerings at  my website.

paul-y

I don't think I deleted any of my program files, but if I can't get the Arduino IDE to run what can I do with them?

CrossRoads

Keep plugging away, you'll get the IDE to start eventually.
I've not had issues like yours, on either an older WinVista machine, or my current Win7Pro machine, don't have much to offer to overcome it.
Designing & building electrical circuits for over 25 years.  Screw Shield for Mega/Due/Uno,  Bobuino with ATMega1284P, & other '328P & '1284P creations & offerings at  my website.

federicofissore

paul-y, please try the following

Open command prompt and "cd" into the arduino ide folder (probably something like C:\Program Files (x86)\Arduino

Then type arduino_debug

If the IDE won't open, you should at least see lot's of stuff being printed on the command prompt. Please copy paste of that stuff here

paul-y

Thank you Federico.

I am not a computer guy, most of this stuff is beyond my ability. what is "cd"? what does it mean?

I have never used the command prompt before. if I get in there can I mess up my computer? should I risk playing around in there? and if I happen to get that far in there I don't know if I will be able to copy and paste the info back here.

Thanks Paul.

 

federicofissore

paul-y then it's best if you ask some friend a hand on this. once you know what prompt is and how it works, it's super easy, but if you don't know it, you can mess up things a lot

kfeger

Hi Frederico,
I did what you asked, starting arduino_debug.exe from the command line. It took on my Laptop about 2 minutes to start, but it started (Win7-64, quad core i7, 8Gb, SSD). While loading, the command Windows showed no Output whatoever.
That seems to me quite a long loading time and is is repeatable.

Sometimes I get the "launch4j"-error also and I don't have a Clou.
The Problem started definitely with 1.6.0. I have a Standard Arduino Installation and also Java-JRE installed. Renaming the original Java or the Arduino supplied Java doesn't make a difference.

Any hint?
Regards
karl

Go Up