Go Down

Topic: [HELP] Launch4j - An error occurred while starting the application. (Read 70083 times) previous topic - next topic


Удалите папку c:\Users\......\Documents\Arduino\ и все будет ОК!


Guida per principianti http://playground.arduino.cc/Italiano/newbie
Unoffical Telegram group https://t.me/genuino


I have tried removing arduino from my documents.  I have tried the deep scan to see if there was any directory problems and no luck there.  I tried the new java and copied that over to the arduino folder and still it will not run.  I was running just fine and then literally the next day I turned on my laptop and it stops working.  I uninstalled it and install that new one and still won't start.  Please someone help.  I have so much work put into this and I am at my wits end.  I am running winblowz 8.1 with all updates.  Also turned off bluetooth and wifi.  Only connected via lan.  Arduino will not startup please help. Here is the report from arduino debug:

C:\Program Files (x86)\Arduino>arduino_debug.exe
Loading configuration...
java.lang.ArrayIndexOutOfBoundsException: 3
        at processing.app.windows.RegQueryParser.parse(RegQueryParser.java:29)
        at processing.app.windows.RegQueryParser.<init>(RegQueryParser.java:14)
        at processing.app.windows.Platform.getFolderPathFromRegistry(Platform.ja
        at processing.app.windows.Platform.recoverDefaultSketchbookFolder(Platfo
        at processing.app.windows.Platform.init(Platform.java:51)
        at processing.app.Base.guardedMain(Base.java:153)
        at processing.app.Base.main(Base.java:137)

C:\Program Files (x86)\Arduino>


Nothing obvious in the log.

Do you have bluetooth? Disable bluetooth and see if that helps. Sometimes that will cause a long delay and will cause the app to timeout.

Also, try moving the Arduino folder from the Desktop.


Mysticforce it's a bug we fixed in the hourly builds and that will be included into 1.6.6
Please try using the hourly http://www.arduino.cc/en/Main/Software#hourly


All you have to do is rename/delete(whatever you prefer) the "java" folder in the Arduino package and copy-paste the java runtime environment located in the program files folder. This is pretty simple hack which came to my mind while just trying to fix the problem. I hope this "technique" works with you.

I had jdk/jre8 installed and built arduino from source. But while launching arduino, I was getting this error: AStylej.dll: Can't load IA 32-bit .dll on a AMD 64-bit platform

Replaced the java folder in arduino folder with correct jre and it worked :)


Nightly Release 1.6.6 worked for me only the first time. Second launch reverted back to closing splash screen then nothing.
c:\Program Files (x86)\Arduino>arduino_debug.exe
Loading configuration...
Initializing packages...
Preparing boards...
        at processing.app.Theme.getStyledFont(Theme.java:150)
        at processing.app.syntax.SketchTextArea.setSyntaxTheme(SketchTextArea.ja
        at processing.app.syntax.SketchTextArea.setTheme(SketchTextArea.java:120
        at processing.app.syntax.SketchTextArea.installFeatures(SketchTextArea.j
        at processing.app.syntax.SketchTextArea.<init>(SketchTextArea.java:81)
        at processing.app.Editor.createTextArea(Editor.java:1027)
        at processing.app.Editor.<init>(Editor.java:271)
        at processing.app.Base.handleOpen(Base.java:875)
        at processing.app.Base.handleOpen(Base.java:860)
        at processing.app.Base.handleOpen(Base.java:856)
        at processing.app.Base.handleNew(Base.java:751)
        at processing.app.Base.<init>(Base.java:455)
        at processing.app.Base.guardedMain(Base.java:219)
        at processing.app.Base.main(Base.java:135)

c:\Program Files (x86)\Arduino>

In my case I had modified theme.txt. My version was shorter and missing some items that 1.6.6 was looking for. Replaced with the the zip theme file and viola. It worked.

Could Arduino please have color selections for tabs, and fonts in the preferences? This would make the interface so much more visible.
And thank you for fixing the sketch tab selection list window!


Go Up