Go Down

Topic: [HELP] Launch4j - An error occurred while starting the application. (Read 65678 times) previous topic - next topic

federicofissore

We've recently fixed a windows+launch4j+java issue. It will be released with 1.6.1 but it's already available as a nightly build http://arduino.cc/en/Main/Software#nightly
Try giving it a spin

kfeger


federicofissore

Can you run it from the command line using arduino_debug.exe and paste the error message here?

Michael_QLD_AU

G'Day All

Go here and try this. No more error LaunchJ4.

https://alselectro.wordpress.com/2014/01/26/arduinosolution-to-launch4j-problem/

Hope this helps

Michael

federicofissore

We have updated bundled java as alselectro did. It's available in the latest nightly and will be part of 1.6.1 http://arduino.cc/en/Main/Software#nightly

menxin

When I run arduino_debug.exe in cmd,it report a exception :jnidispatch(....jna/win32-amd64/...) not found in resource path. I locate jna.jar,the path(win32-amd64) not found.So I download the newest version jna.4.0.1.jar and replace lib/jna.jar,the exception has disappeared.

Run arduino.exe ,the dialog is not come,But the IDE is not opened.No exceptions no Logs and no IDE,only a splash form.


Windows 8.1 pro X64


On my other computers,use the same old jna.jar,also in Windows 8.1 pro X64, was all right.....

menxin


menxin

[solved]

1.Update jna.jar to newest version.

2.Download astyle source code,compile it with X64 profile.

3.Install vcredist_x64.exe to support your new astylej.dll (X64).


My problem is java X86 cant run in my windows pro 8.1 WOW64,so i have to install java X64,becasue arduino IDE is 32bit,and some of its lib is 32bit,cant run in x64 env. So replace 32bit lib to 64bit version can solve this problem.

Wish arduino can publish 64bit IDE.....

federicofissore

menxin this is news to me: thought windows could run 32 bit binaries with no issues. We'll schedule the release of a 64 bit windows ide

federicofissore

Your issue is being tracked here https://github.com/arduino/Arduino/issues/2763

pjrc


federicofissore

A windows pro 8.1 WOW64
What's even more strange is that even the toolchain is 32bit, so the IDE should not even compile a sketch

Flight_Jockey

@jknutter :  in the subfolder Libraries , i have not found any subfolders called Libraries nested off each other.

SO  WHAT IS THE SOLUTION !!!
I don't know if this has been the case for others, but what appears to have led to my 44 deep nested libraries folder (before I caught it, it probably would have continued), 18GB in size, was that I inadvertently attempted to Import Library/Add Library on the root library folder.  What a mess! 

I'm not even going to try to replicate this mess.

Garvord

per http://www.ultratechnet.com/2013/01/arduino-problem-invalid-window-handle.html

"SOLUTION:
All you have to do is rename/delete(whatever you prefer) the "java" folder in the Arduino package and copy-paste the java runtime environment located in the program files folder. This is pretty simple hack which came to my mind while just trying to fix the problem. I hope this "technique" works with you.

Active Bluetooth device also seemed to be a probable cause for the problem, also responsible for slow behavior of the arduino IDE. Turn off the bluetooth device of your laptop, i.e disable the network and try again launching the application."

Worked for me.
Yes. This worked for me:-)

How-To:
1. Goto to your Arduino install directory and rename the C:\Program Files (x86)\Arduino\"java" folder to "java.bak".
2. Copy the java folder (C:\Program Files (x86)\Java\jre7) to your Arduino install directory (C:\Program Files (x86)\Arduino\jre7) and rename it to C:\Program Files (x86)\Arduino\"java".


Windows 8.1 Enterprise 64bit
Arduino IDE 1.6.1
Java SE Runetime Environment 7

federicofissore

2 years old and should be fixed with 1.6.1. Can you please run arduino_debug from the command prompt and past the output?

Go Up