Go Down

Topic: Deploying on ATMega 328p with Ethernet Shield (Read 459 times) previous topic - next topic

adhambadr

Hi guys,

Since some weeks I am very interested in deploying my arduino project on an independent board/chip (so that I can power it up with a battery or sthng and use it without my arduino), I chose therefore the 328p Atmega. After going through the pain of building its circuit and programming it with the Arduino and deploying a test blink program everything worked so far. Now I am trying to connect an ethernet shield (Sparkfun PoE ethernet shield) to the Atmega to connect it to the internet. The software and connections already worked on the Arduino board, but when I replicate it on the Atmega its not working and having very weird behaviour.

I connect the ATmega with the Shiled as follows :
Ethernet Shield              Atmega 328
MISO                            18 (Miso)
MOSI                            17 (MOSI)
SCK                              19 (SCK)
CS

I am unfortunately no electronic expert and without the bildr, instructables and the nice people on this forum I would have never reached that far, but I have reason to believe its an electronic connection/resistors misplaced problem because it worked once and then as soon as I reset the circuit it doesnt work anymore. I think It has to do with the pullup/pulldown resitors on the Reset pins ? Do I need resisitors on the SPI pins ?

Erdin

Answered in other thread: http://forum.arduino.cc/index.php?topic=168498.0

Go Up