Go Down

Topic: driver properly installed; sketch sucessfully complies, but no results on Uno (Read 1 time) previous topic - next topic

Zita

Hello.  About two weeks ago, I started playing around with Uno R3 on Window 7 and Arduino 1.0 IDE.  Everything was working fine, until I ran into a problem this week.

Description of the Problem:
1) Driver is installed properly and computer recognizes the Arduino.  Sketch is complied successfully, but nothing happens on the board.
     - I have tried this with the blink sketch and other simple sketches.
     - During these trials, both the ON and L leds are lighted up.  However, the L led does not blink when the sketch is done complying like it did before when everything was working fine.

3) The Arduino fails the loop-back test.  When I type something into the serial monitor, the RX led lights up.

What I have done so far:
1) I have read and followed the guidelines on the Arduino troubleshoot page, but nothing worked.

2) I have tried installing different IDEs.

3) I bought a second, new, and working-properly Uno R3, but the problem still persists.
     - I uploaded the blink sketch using the same USB cable onto the new Uno.  Sketch was complied successfully but no physical results on the board.

4) I have uploaded the blink sketch on both Uno's on two other computers (one is Window 7 and the other is Window XP).  The driver were installed properly on all computers and the sketch was complied successfully; but no physical results on the board.

5) The new Uno also fails the loop-back test.

I have noticed that the sketch complies successfully whether the Arduino is plugged in or not.  When I didn't have the problem before, I got an error message when the Arduino was not plugged in while the sketch was being uploaded.  The only thing I haven't tried is using a different USB cable.  Perhaps, that is the problem.  Any suggestions would be greatly appreciated.

Thank you,

Zita

CrossRoads

Select File:Preferences, and click Verbose Output for compilation & upload.
Report what you see when you compile & upload.

Also, update to IDE 1.0.5, the latest.
Designing & building electrical circuits for over 25 years.  Screw Shield for Mega/Due/Uno,  Bobuino with ATMega1284P, & other '328P & '1284P creations & offerings at  my website.

Zita

Thank you for replying so quickly.  Fortunately, I have figured out the problem.  I have been using the verify button to upload sketches;  I did not know there was a difference between the two.

DcmD

I have been having similar problems. I bought a duemilanove board and the sketch compiles fine but when I upload  the LED will blink once although its on infinite loop.

I've changed the usb, tried it on both windows 7 and mac OS X, but still no luck. The drivers are correct and work, the right board  and serial/com port is selected.
It's becoming very annoying as I feel I've been trying everything.
Any help at all would be most appreciated.

my code


Code: [Select]
int ledPin=13;

void setup ()
{
  pinMode(ledPin,OUTPUT) ;
}

void loop ()
{
  digitalWrite(ledPin,HIGH);
  delay(1000);
  digitalWrite(ledPin, LOW);
  delay(1000);
}

CrossRoads

Under File:Preferences, check the verbose output boxes.
Upload again, and post any errors that are being reported.

I have a Duemilanove also, but it has been re-loaded with Uno bootloader, so I select Uno when I load code into it.
Designing & building electrical circuits for over 25 years.  Screw Shield for Mega/Due/Uno,  Bobuino with ATMega1284P, & other '328P & '1284P creations & offerings at  my website.

Go Up