Go Down

Topic: Arduino Micro - IDE trying to upload to wrong COM Port ! (Read 6019 times) previous topic - next topic

kburndred

:(
I have a Micro that is setup on COM9.  Whenever I try to upload a sketch the IDE says it's uploading and after a short while the Micro reboots. The IDE still says uploading and after about a minute the IDE reports the following error.

  avrdude: ser_open() can't open device "\\.\COM8": The system cannot find the file specified.

I have tried to attach a screenshot of the arduino IDE that shows the issue. In the statusbasr you can see "Arduino Micon on COM9"
I also have the tools,Serial Port menu visible and you can see COM9 is checked.
I have the correct board selected.
I have tried various versions of the IDE and all do the same thing.
I have also tried 2 different computers and they both do the same thing. Windows7 64bit and Windows XP SP3
I decided to try a new Micro board, exact same problem.
I have tried all kinds of sequences of pressing the reset button and holding it. Pressing the reset button momentarily when the IDE
says uploading.
I have checked windows device manager and I have "Arduino Micro COM9"
I have also made sure that the correct drive is installed.
I have uninstalled the COM9 from windows and re-installed also.

I also have an Arduino MEGA2560 that works perfectly on the same 2 computers.
I also have an Arduino UNO that works perfectly on the same 2 computers.

I am looking for a solution that will allow me to upload sketches to my Arduino Micro. If it's a procedural thing that would be great, I just need to know what the magic is.........

Thanks to anyone that can help.


Louis Davis

The Micro is very similar to the Leonardo.
It is normal to have two different COM ports. One for sketches and another when the bootloader is running.

See here for more detials:
http://arduino.cc/en/Guide/ArduinoLeonardo

If you open Device Manger and watch the Ports section, what happens when you press the reset button and release it?

You should see COM9 disappear and you should see another COM port appear.


kburndred

Hi, thanks for the help.  I do see the COM port disappear and then re-appear as the bootloader port. I modified the COM port so that they are both coming in as COM8.  The IDE still will not upload any sketches at all.

cmiyc

1.5.2 is a beta released intended to support the Due.

You may want to try 1.0.5 and see if you have the same behavior.
Capacitor Expert By Day, Enginerd by night.  ||  Personal Blog: www.baldengineer.com  || Electronics Tutorials for Beginners:  www.addohms.com

kburndred

I figured out what the issue was.
I had to disable all my other virtual COM ports in windows device manager.
I have 6 virtual COM ports that are setup to communicate with the Lantronix Matchport b/g when it's powered up.
If these Lantronix devices are not powered up the Arduino IDE couldn't figure out what to do. 
Also the Tools menu took a very long time to come up.
Once I disabled my other virtual COM ports, everything worked perfectly with the Arduino IDE 1.5.2 and the Micro

Thanks

Louis Davis

I think you have identified one of the limitations of the Leonardo/Micro bootloading behavior.

When you upload code to the Leonardo/Micro it causes the device to reset.
When the bootloader is enumerated by the system, the IDE doesn't know what COM port it will appear on, so it will poll each of the available COM ports until it gets the desired response and then continues with loading the new sketch.

Glad you were able to get it working.

This behavior is something to keep in mind to help others troubleshoot similar symptoms.

Go Up