Go Down

Topic: DMF5005N optrex (Read 6567 times) previous topic - next topic

gunthervde

Hello,

Can someone tell me how to connect a DMF5005N to Arduino.
And if there is something I have to download for library.

Manny thanks in advance.

olikraus

#1
Jul 02, 2013, 12:26 am Last Edit: Jul 02, 2013, 07:13 am by olikraus Reason: 1
As usual, a link to the datasheet would help. After some internet search, i found this: http://www.kyocera-display.com/SiteImages/PartList/SPEC/DMF5005N-COE-DDN_Eng.pdf

According to the datasheet, the display has a size of 240x64 pixel (page 2)
The controller is a T6963 (page 2)
The contrast setup is shown on page 8, but i do not think that you need a transistor. A simple variable potentiometer will be good enough. But you will need some -15 V (I have used a DC-DC converter module for this).

Once done with the electrical setup, you can use u8glib (http://code.google.com/p/u8glib/):

Code: [Select]
U8GLIB_T6963_240X64(d0, d1, d2, d3, d4, d5, d6, d7, cs, a0, wr, rd [, reset])

Notes:
1. cs = c/e (pin7) and a0 = c/d (pin 8 )
2. Connect FG and (IMPORTANT!!!) FS to 0V

Oliver

gunthervde

Thanks for you reply Olikraus,

But I'm not a expert at this moment  :smiley-red:
I found this LCD in the trash at work and I'm sure he's still ok, but can you gide me trough how to connect the 20 pins?

1: FG -> gnd
2: VSS -> gnd
3: VCC -> +5V
4: VCC -> +5V with potmeter for contrast
5,6 -> 20 ???

I can work with a normal 16x2 LCD with the #include <LiquidCrystal.h>
Do you have some drawing of the wiring and some code?

Many thanks in advance,
Gunther

So after I wired it up what kind of include do I need to use?


olikraus

#3
Jul 02, 2013, 07:12 pm Last Edit: Jul 02, 2013, 07:34 pm by olikraus Reason: 1
Hi

Please have a look here: http://forum.arduino.cc/index.php?topic=172563

I suggest to connect the variable pot as described here (page 4): http://www.newhavendisplay.com/specs/NHD-24064CZ-FSW-GBW.pdf

For the graphics lib: Download U8glib v1.12 from here: http://code.google.com/p/u8glib/downloads/list
Follow the install instructions in "install.txt"

Let me know if you have more questions.

Oliver

Edit: VEE in the refered data sheet must be replaced by the output of an extern negative voltage source (-15V)

gunthervde

Hello Olivier,

thanks for answering.

I'm new with lcd's so ... I'm a little bit stupid  :smiley-roll-sweat:

This LCD http://www.futurlec.com/LED/LCD16X2BL-3V3.shtml I can work with
but it's the dmf5005N is compleet differend if you look at http://www.kyocera-display.com/SiteImages/PartList/SPEC/DMF5005N-COE-DDN_Eng.pdf

When I put 5VDC on pin A and K on the side of the LCD I have the backlight comming on.
Pin 11->19 is D0 ->D7 and is for the data like on the 16x2 lcd
But I don't know how to connect all the other pins.

This is also what I found on the net: http://www.avrfreaks.net/index.php?name=PNphpBB2&file=viewtopic&t=27405
http://www.flickr.com/photos/samwibatt/2619732545/

I don't have a electronic background but I try to learn it.
So if you can help me with the wiring and a test code I would be verry happy to start with.

Kind Regards
Gunther





olikraus

#5
Jul 03, 2013, 09:06 pm Last Edit: Jul 03, 2013, 09:32 pm by olikraus Reason: 1
Hi

1) Download u8glib
2) install u8glib in the libraries folder (unzip there)
3) start arduino IDE
4) You should see the u8glib submenu in the Examples section
5) locate "HelloWorld"
6) open "HelloWorld" example
7) Find this line in the example:
Code: [Select]
//U8GLIB_T6963_240X64 u8g(8, 9, 10, 11, 4, 5, 6, 7, 14, 15, 17, 18, 16); // 8Bit Com: D0..D7: 8,9,10,11,4,5,6,7, cs=14, a0=15, wr=17, rd=18, reset=16

8 ) Uncomment this line:
Code: [Select]
U8GLIB_T6963_240X64 u8g(8, 9, 10, 11, 4, 5, 6, 7, 14, 15, 17, 18, 16); // 8Bit Com: D0..D7: 8,9,10,11,4,5,6,7, cs=14, a0=15, wr=17, rd=18, reset=16

9) Ensure that the arduino board is not connected to any power or usb
10) Connect your display as described in the comment: // 8Bit Com: D0..D7: 8,9,10,11,4,5,6,7, cs=14, a0=15, wr=17, rd=18, reset=16
10a) Connect Data lines from D0 to D7 to pins 8,9,10,11,4,5,6,7
10b) Connect the chip enable display pin (called cs in U8glib) to pin 14, which is labled as A0 on the Uno
10c) Connect the c/d display pin (called a0 in U8glib) to pin 15, which is labled as A1 on the Uno
10d) Connect wr, rd and reset to 17, 18, 16, which are A3, A4, A2
11) Connect FS to 0V (Gnd)
12) Connect FG to 0V (Gnd)
13) Create a -15V source. Best is to use a DC/DC converter, which creates -15V from +5V. Of course for testing any -15V power soruce will be ok. For example 10x 1.5V AA batteries: Connect +15V of the batterie back to GND and the GND of the battery pack will be -15V.
13) The variable potentiometer: Connect one end to GND, connect the other end to -15V, connect the wiper to V0

Oliver

Edit:
14) Connect Arduino to your PC, download "HelloWorld" example. Adjust wiper until you see the HelloWorld String. Optional: Post a picture of the result.

gunthervde

#6
Jul 04, 2013, 09:13 am Last Edit: Jul 04, 2013, 09:21 am by gunthervde Reason: 1
Hello Olivier,

Thanks for your clear explanation  :)

first I will make a DC inverter.


I let you know the result.

Kind Regards,
Gunther


Dacflyer

how is this project going, curious if he ever got it going or not..
BR-549

machinofacture

I have also attempted to do this.

Here's a picture of my setup:

http://imgur.com/B9goHRk

Unfortunately, I can only get my LCD to show two lines and that's it.

It shows a few more horizontal lines when the arduino reboots but then nothing. Two lines and that's it.

Any ideas?

I am running the "hello world" example from u8g library as mentioned by olikraus, above.

machinofacture

Update:

It was working! The problem was the contrast voltage was set up incorrectly. I haven't really solved that problem, just run into a new one.

To recap though, Vcc-Vee voltage must be around 10-11V to display correctly.

So my setup is to have a 10k resistor connected to one side of a 5k pot, and the other side connected to -16V coming from a wall wart power supply. The wiper produces -4 to -16 V.

Here's a video demonstrating the problem I'm having. The voltage won't stay steady!

https://www.youtube.com/watch?v=Yp2oE9SHh1c

machinofacture

Update:

I replaced the two little electrolytic capacitors on the back of the display, and now it works perfectly!!

So the conclusion is, if your display is being wonky, try replacing the capacitors!!

Just for future reference, the rating of those capacitors is: 10 uF, 16 V and 4.7 uF 35 V

http://imgur.com/iZDcMdW

hsamet

Dear , I have the MEGA 2560  and I want to use the 240x64 display moduleDMF5005 .
I just hook up all pin (as described  above ) , but I need  more clarification on  PIN  A0 A1A2 A3 A4 .
 ---->In MEGA  version .there is PIN 14,15,16,17,18  and ALSO   A0 A1 A2 A3 A4  .
my question is: What I must use ?
 the syntax is ?
U8GLIB_T6963_240X64 u8g(8, 9, 10, 11, 4, 5,6, 7, 14, 15, 17, 18, 16); // 8Bit Com: D0..D7: 8,9,10,11,4,5,6,7, cs=14, a0=15, wr=17, rd=18, reset=16

I connect 5 V to VCC
VSS is connected to ground   and
VEE connected to power negative  -10 V

thank you in advance .

Go Up