Go Down

Topic: WIFI Shield firmware update 1.0.5 attempt (Read 12863 times) previous topic - next topic

SurferTim

Look at reply #9 and reply #11. That is the output from a successful upgrade.

alexis10clement

Hi Ric,

Thanks for your reply !

This is a screenshot of my command prompt ...

- Directory : C:\Program Files (x86)\Atmel\Flip 3.4.7>
- Files in this directory
- Command line I use : batchisp.exe -device AT32UC3A1512 -hardware usb -operation erase f memory flash blankcheck loadbuffer wifiHD.elf program verify start reset 0

What is the problem ? Please !!!

Thanks,

Alex

SurferTim

#17
Apr 23, 2014, 11:53 pm Last Edit: Apr 23, 2014, 11:56 pm by SurferTim Reason: 1
There doesn't appear to be a problem. It looks like it worked to me. What makes you think there is a problem?

edit: Insure you do the same for wifi_dnld.elf

alexis10clement

#18
Apr 24, 2014, 12:42 am Last Edit: Apr 24, 2014, 12:45 am by alexis10clement Reason: 1
I resume :

Shield wifi not connected to arduino mega 2560

- First step : jumper on shield wifi
- Upgrate wifi_dlnd
- Reset button on shield
- Upgrate wifi_hd
- Reset button on shield
- Disconnect jumper

Connect shield to arduino mega 2560

In my code I write :

if (WiFi.status() == WL_NO_SHIELD)
 {
   digitalWrite(9, HIGH);
   while(true);
 }

And my LED is ON !!! :(

What step is wrong ?

Thanks for your help ... I am going crazy !!!

Alex

SurferTim

It sounds like you have a problem with the physical connection of the shield to the Arduino. Are you sure the shield is seated correctly and completely on the Mega?

Is the Mega2560 a R3 model also? If not, there will be two overhanging shield pins on each side, and that will require a jumper wire from the 5v to the ioref pin on the shield.

alexis10clement

I have the Mega 2560 ADK (http://arduino.cc/en/Main/ArduinoBoardMegaADK).
There is a difference with Mega 2560 ? Something to change with hardware or software ?

SurferTim

If it is a R3 board, then it should not have any pins overlapping. Insure the ICSP pins in the center of the Mega are inserted correctly into the shield socket. Those are the SPI data pins.

rperegrino

Hello,

I thought I read that the WiFi shield works w/ the 2560, not the ADK, as I think there's a SPI conflict. This is consistent with WiFi.status == WL_NO_SHIELD.

Also, I didn't think the wifi_dnld.elf download works or is required. I thought the wifiHD.elf download is the one that works, and when it is downloaded that it clobbers any previous download. In other words I thought downloading ONLY the wifiHD.elf is sufficient.  Or in other words, that downloading the wifi_dnld.elf after the wifiHD.elf would not work.

Regards,
Ric

SurferTim

Both these upgrades are required. Use the files that are included with IDE v1.0.5.
wifiHD.elf
wifi_dnld.elf

dizzFish

Hi friends of the WiFi-Shield,

I struggled with the same issues and now I think I found THE SOLUTION to the problems with "Can't open..."....

It's a problem with Windows protection of the Progams-folder. I just copied the files into C:\temp and ran the isp-command (as described in http://arduino.cc/en/Hacking/WiFiShieldFirmwareUpgrading. Just erase the path then and it works. Maybe the program tries to open the file for writing?!

Cheers

sspence65

I put the two files in a temp directory, they upload ok, I get the blue light on constantly, and "Wifi Shield Not found" ...
Steve Spence - KK4HFJ

HovCo


Arduino support sent me a wifiHD.elf file for 1.0.5 and it worked perfectly for me.  This is supposed to be the same file in the IDE 1.0.5.  If you are having trouble upgrading the firmware on the wifi shield to 1.0.5, please contact me and I will send you the file and answer other questions you have with upgrading.

I used wifi_dnld.elf and wifiHD.elf from github and IDE 1.0.5-r2\hardware\arduino\firmwares\wifishield. UDP can be received by Arduino Uno R3 with wifi shield. However, UDP packet can not be sent to other machine! Also, ping cmd from other machine to the wifi shield works well! That is weird.
want to test the two files with IDE 1.0.5-r2
Could you share them?

IEM123

#27
Jul 09, 2015, 07:16 am Last Edit: Jul 09, 2015, 07:36 am by IEM123
why i  stop at
 Opening port........................... AtLibUsbDfu: 3EB 2FF8 no device present.
FAIL   Could not open USB device.

espkh4

I have tried looking for a solution but none works except the one below for me. I referred to this link:

http://mssystems.emscom.net/helpdesk/knowledgebase.php?article=50

Navigate to your Arduino folder that contains 'wifi_dnld.elf' file. It CANNOT be any other working directory that happens to contain the stated file above. Why is this so? I have no idea. For my case it is:

C:\Program Files (x86)\Arduino\hardware\arduino\firmwares\wifishield\wifi_dnld\Release

So using Command Prompt, I navigate to the above and run the following command:

batchisp.exe -device AT32UC3A1512 -hardware usb -operation erase f memory flash blankcheck loadbuffer wifi_dnld.elf program verify start reset 0

Follow the instructions on the website about reseting after seeing the blue led. Then the second part would be navigating to where the 'wifiHD.elf' is located(using command prompt). For my case, it would be:

C:\Program Files (x86)\Arduino\hardware\arduino\firmwares\wifishield\wifiHD\Release

Then I run the following command:

batchisp.exe -device AT32UC3A1512 -hardware usb -operation erase f memory flash blankcheck loadbuffer wifiHD.elf program verify start reset 0

I will get warning message about overlap. But it is ok. As long as there is no red colour Error about file input. Hope this helps someone because I spent almost a day trying to reoslve this and thought of sharing.

Best regards

Wolfraam

I've been looking at starting my Arduino shield, uploading the firmware several times. Getting frustrated along the way untill it hit me: my shield drew too much power and my USB line couldn't handle it.

So: When you want to test it with the example sketches, be sure to hang it up an external supply, the USB alone can't pull enough power

Go Up