Go Down

Topic: probleme usb Arduino nano ch340 (Read 984 times) previous topic - next topic

loo

Bonjour, ma carte arduino nano achetéee chez banggood fonctionnait bien jusqu'à il y  a deux jours

(j'ai entre temps soudée celle ci sur circuit imprimé et fait mon montage), mais maintenant...

Elle est reconnue comme "périphérique usb inconnu" sous windows.

Et donc impossible de sélectionner le port Com sous arduino IDE

Avant de venir ici, j'ai épluché tous les forums anglais francais que j'ai trouvé et ai donc essayé plusieurs

solutions).

Dans le gestionnaire de périphériques: installer les pilotes trouvables dans "programefiles86/arduino/drivers"  à la mais: windows me dit que les meilleurs pilotes sont déja installés

J'ai installée le driver ch340 pour les nanos 'clones', windows me dit "the driver is successfully pre installed in advance". J'ai même essayé d'installer ce pilote sur le périphérique inconnu via le gestionnaire de périphériques)

Pour info, je suis sous windows 10 et ait essayé sous un autre pc windows 7: même problème

Je commence à m'arracher les cheveux...

Une idée...??

merci d'avance

J-M-L

Moi j'explorerai ce côté là pour des courts circuits
Quote
j'ai entre temps soudée celle ci sur circuit imprimé et fait mon montage
Hello - Please do not PM me for help,  others will benefit as well if you post your question publicly on the forums.
Bonjour Pas de messages privés SVP, postez dans le forum directement pour que ça profite à tous

loo

Oui merci.., j'ai complètement dessoudé la carte, testé quelques modifs...mais rien n'y fait.

J'en commande une autre, on verra bien du coup si c'était un problème matériel ou de driver..

J-M-L

#3
Jan 06, 2018, 11:34 am Last Edit: Jan 06, 2018, 11:35 am by J-M-L
Pas de trace de soudure entre les pins 0 et 1 ou GND et Vcc ou entre reset et une autre pin? Testez la continuité avec un voltmètre

À quelle température soudez vous ?
Hello - Please do not PM me for help,  others will benefit as well if you post your question publicly on the forums.
Bonjour Pas de messages privés SVP, postez dans le forum directement pour que ça profite à tous

Artouste

Moi j'explorerai ce côté là pour des courts circuits

bonjour
+1 avec JML
Photos recto/verso en bonne resolution ?

fdufnews

Les bonnes résolutions ça ne dure jamais longtemps passé la mi-janvier c'est oublié.... :smiley-mr-green:

loo

'Pas de trace de soudure entre les pins 0 et 1 ou GND et Vcc ou entre reset et une autre pin? Testez la continuité avec un voltmètre'

À quelle température soudez vous ?'

J'e n'ai que vérifié qu" entre GND et Vcc,  pas entre 0 et 1...

C'était peut être ça du coup,et j'ai jeté la carte, y ayant passé trop de temps à mon gout..

Je devrais rajouter la patience à mes bonnes résolutions! ;)

Pour la température de soudure, je dirai 300 en essayant d'aller assez vite.

Je vous dirai du coup quand j'aurai reçu la nouvelle si c'était un problème matériel ou logiciel.

Merci pour l'aide




Alain46

Pour les ESD (Electrostatic Sensitive Device), un fer à souder antistatique est aussi une bonne idée
Un programme qui se compile sans erreur n'est pas forcément un programme qui fonctionne.

Jambe

C'était peut être ça du coup,et j'ai jeté la carte, y ayant passé trop de temps à mon gout..

C'est dommage de jeter aussi vite, il n'y avait peut être pas grand chose

68tjs

Quote
Pour la température de soudure, je dirai 300 en essayant d'aller assez vite.
Moi je mets 390 (le max que mon fer peut faire), justement pour aller très vite.

Je sais que cela dépasse fortement la température recommandée mais entre passer plusieurs minutes à faire fondre la soudure à 300 ° et seulement quelques secondes à 390 je dis que la deuxième solution martyrise moins les composants.

Barsa972

Salut,

J'ai eu un lot de nano ch340 également achetées chez Banggood qui n'ont jamais voulues être reconnues en USB car elles n'avaient pas de bootloader. Il m'a fallu utiliser une Uno comme ISP pour mettre le bootloader et charger le programme dans la nano. Aucun problème. Par contre je n'ai pas essayé de rebrancher la carte en USB après avoir installé le bootloader vu que j'étais déjà câblé sur la UNO.
Dans ton cas, ta carte a fonctionné en USB à un moment donné mais ça aurait quand même valu le coup que tu testes ça. Si jamais il t'en reste, tente le coup...

Go Up