Go Down

Topic: UsbtinyISP in arduino IDE (Read 4056 times) previous topic - next topic

Portal

I'm trying to program the arduino uno with a usbtiny but after selecting ubstinyisp under programmer. But I upload the blink code but Iit says, "Com 3" not found. What do I do
?

runaway_pancake

Is the USBtinyISP connected to COM3?
Is it on another COM (Tools \ Serial Port dropdown) ?
"Who is like unto the beast? who is able to make war with him?"
When all else fails, check your wiring!

hugo007

#2
Jul 07, 2013, 07:25 pm Last Edit: Jul 07, 2013, 07:32 pm by HugoPT Reason: 1
Quote
with a usbtiny but after selecting ubstinyisp under programmer

Well if you are using a usbtinyisp the to upload the program you must go to file and then use the option "Upload using programmer"
Quote
@Runaway Pancake
Is the USBtinyISP connected to COM3?

Usbtiny programmer does not use Serial Port.
You know uploading the code using the usbtiny will overwrite the bootloader right?
This is not a problem just a feature.
Debian,Mint,Ubuntu
Arduino Mega 2560
Arduino Nano
Arduino Duemilanove
MAC OS Montain Lion
Raspberry PI Model B

runaway_pancake

#3
Jul 07, 2013, 07:32 pm Last Edit: Jul 07, 2013, 08:17 pm by Runaway Pancake Reason: 1
Tools \  Board
Select [usbtinyisp]ATmega328
(if that's what it is)
click the Upload button from there (No?)

> > > >
OK.  I hadn't noticed that before, but the USBtinyISP doesn't show up in the Serial Port dropdown.

I broke away, got mine out, and plugged it in and all.
It uploaded sketches whether COM1 or COM3 checked.

When I plug the USBtinyISP in, I get the Windows confirmation "dingdong", and the green LED goes on.  The red one goes on during transfers.

Found I forgot a step about burning bootloaders, too.  Put that in my notebook.

"Who is like unto the beast? who is able to make war with him?"
When all else fails, check your wiring!

Portal

Cool thanks guys, I had to hit ctrl + shift + u or go to file upload using programmer.

Cactusface

Hi All,
            Not quite the same thing but it seems that in any one programming period, if I unplug my Uno to test then re-connect to program, good old Windows re-assigns the port so the upload stops, requesting another port to be selected. I am sure this is another windows querk!! even on Win-7 64bit. I sometimes wish I was still using a MAC...

Regards
Mel.
Open your mind! But not too far, your brains might fall out.
Also like Photography, model building and my 300+ Cacti and Succs.

Go Up