Go Down

Topic: Problema programmazione arduino uno (Read 11012 times) previous topic - next topic

minimanimo

No non mi sono spiegato bene..
Dopo un pò di prove ho tolto tutto e scaricato lo zip dell'ide 1.0.5 e installato i relativi driver manualmente, non dall'installer.
Il programma lo avvio da quella cartella (arduino.exe).
La cartella è posizionata in C:\

vectorel

Hai un computer che ha la porta parallela?

Se hai un'altro computer, oltre a quello che stai usando adesso, prova ad installare l'IDE di arduino e vedere se ti da lo stesso problema.

PaoloP

Su windows7 e windows8 la root e le varie directory programmi, windows ecc, sono directory speciali a volte con permessi di sola lettura o esecuzione ma non di scrittura.
Se possibile usa l'installer della 1.0.5 o se non vuoi scarica e sposta la directory Arduino in un altro disco o partizione. Es D: E: o altre.
Una volta che si è sicuri che non ci sono problemi software dovuti al sistema operativo possiamo passare ad analizzare gli eventuali problemi della scheda.

minimanimo

#18
Jul 14, 2013, 01:06 am Last Edit: Jul 14, 2013, 01:10 am by minimanimo Reason: 1
I driver installati ora sono quelli dell'ide 1.0.5,ho provato ad avviare l'ide da tutto,da installer,da zip,ma nulla,stesso problema.
I file dello zip sono stati spostati in varie cartelle,anche in un'altra partizione,ma sempre stesso problema.
ho provato la board su un pc provvisto di porta parallela e seriale,con windows xp 32 bit,installer 1.0.5 ma stesso errore. :'(


http://www.sonsivri.to/forum/index.php?topic=27727.0
puoi tentare con questo

Entrambi i siti non sono accessibili,uno è stato chiuso e l'altro fà il redirect su siti pubblicitari.. mi stò demoralizzando. XD

superlol

http://www.aug-altogarda.it/ <- Il nuovo AUG per basso trentino e dintorni!

minimanimo

#20
Jul 14, 2013, 01:33 am Last Edit: Jul 14, 2013, 01:38 am by minimanimo Reason: 1
lo ho già fatto,tranquillo..era solo per informativa :D

Ho trovato nello stesso forum la documentazione..ma il bootloader di arduino uno dove lo trovo?

o devo programmare l'hex del blink direttamente? (credo di no).

vectorel

Visto che hai un computer con la porta parallela, a questo punto puoi provare a caricare il bootloader con quella seguendo questa guida http://www.arduino.cc/en/Hacking/ParallelProgrammer?from=Main.ParallelProgrammer per collegare le resistenze ai cavi e quest'altra per ricricare il bootloader http://arduino.cc/en/Tutorial/ArduinoISP

Invece di selezionare "Arduino as ISP" però devi selezionare "Parallel programmer" e ovviamente non ti serve un altro Arduino

minimanimo

#22
Jul 14, 2013, 03:15 pm Last Edit: Jul 14, 2013, 04:12 pm by minimanimo Reason: 1
Ciao..ho provato ma niente,non me lo fà riscrivere il bootloader:

avrdude: can't open device "giveio"

avrdude: failed to open parallel port "lpt1"

Nonostante il giveio.sys è stato installato!
Non so come muovermi..
------------------------------------------------------------
EDIT: Progressi,ma sempre errori:
------------------------------------------------------------
avrdude: AVR device not responding
avrdude: initialization failed, rc=-1
avrdude: Yikes!  Invalid device signature.
avrdude: Expected signature for ATMEGA328P is 1E 95 0F

-----------------------------
Ho controllato i collegamenti,sono fatti bene (ho provato con cicalino dai fili ai pin dell'atmega).
Corrispondono:
http://www.gammon.com.au/images/ArduinoUno_R3_Pinouts.png
e
https://content.solarbotics.com/products/photos/ce7a45084987622821fe5b8ba755eeae/lrg/28960-pinout.jpg

superlol

allora mi sa che hai corrotto l'ide.

disinstalla e cancella tutte le cartelle di ide che hai sul pc.
quindi installa da installer l'ide 1.0.5 (assicurandoti di far installare anche i driver)

collega arduino, aspetta che venga riconosciuta ed apri l'ide, seleziona la porta com e la scheda, NON toccare nulla che riguarda i programmatori.

quindi prova a caricare l'esempio del blink.

se non funziona dicci cosa fa la scheda appena alimentata senza aggiungere altro e finchè non ti diamo istruzioni tieni a posto le manine  XD
http://www.aug-altogarda.it/ <- Il nuovo AUG per basso trentino e dintorni!

PaoloP

Riguardo la programmazione parallela lascia perdere, funziona una volta su 1000.
Usa la ISP, eventualmente con un'altro Arduino o altro programmatore.

Ho perso un po' il filo del topic. Non è che fai un riassunto delle prove effettuate?

minimanimo


allora mi sa che hai corrotto l'ide.

disinstalla e cancella tutte le cartelle di ide che hai sul pc.
quindi installa da installer l'ide 1.0.5 (assicurandoti di far installare anche i driver)

collega arduino, aspetta che venga riconosciuta ed apri l'ide, seleziona la porta com e la scheda, NON toccare nulla che riguarda i programmatori.

quindi prova a caricare l'esempio del blink.

se non funziona dicci cosa fa la scheda appena alimentata senza aggiungere altro e finchè non ti diamo istruzioni tieni a posto le manine  XD


Considera che ho installato l'installer di arduino 1.0.5 e relativi driver,non modificando nulla,su windows xp 32 bit,provo a programmarlo con blink,ma mi dà il solito errore,cioè :
avrdude: stk500_getsync(): not in sync: resp=0x00

Quindi non ho corrotto l'ide.. è quacols'altro.
Appena avvio la programmazione dall'ide, sull'arduino si accende intermittentemente 3 volte il led Rx,ma non il tx.


Riguardo la programmazione parallela lascia perdere, funziona una volta su 1000.
Usa la ISP, eventualmente con un'altro Arduino o altro programmatore.

Ho perso un po' il filo del topic. Non è che fai un riassunto delle prove effettuate?

Le prove fatto fino adesso sono state quelle di programmare arduino da un pc con windows 8 64 bit e uno con windows xp 32 bit con ide 1.0.5 e relativi driver,ma niente..
Ho provato anche a riprogrammare il bootloader tramite parallela ma niente,vorrei provare usando il pickit v2,ma è un casino.

PaoloP

Prova con la manovra di emergenza.
Su Xp puoi usare un qualsiasi IDE, su Win8 l'1.0.4 e successivi.

Manovra di emergenza --> http://forum.arduino.cc/index.php?topic=131955.msg992873#msg992873

minimanimo

Grazie Paolo..Quella è la prima cosa che ho fatto..il problema è che quando premo il pulsante di reset,non cambia niente (c'è chi dice invece che al premere del bottone,deve lampeggiare il led).
Ho provato a modificare il file blink mettendo un dealy da 2000 prima di tutto..ma non lo carica.
Mi stò demoralizzando.. ho provato col pickit2 ma non riesco a programmarlo..

menniti

L'errore errore "avrdude: stk500_getsync(): not in sync: resp=0x00 avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51" indica il non corretto funzionamento del reset, nel tuo caso un probabile mancato dialogo tra PC e micro di Arduino, potrebbe essere una questione di bootloader. Nella mia Guida attuale non c'è ma su Elettronica In ho pubblicato la tecnica "BitBang" che richiede solo un convertitore USB-seriale basato su FT232RL, ma che abbia disponibili tutti i suoi pin; questa tecnica permette di ricaricare direttamente sul micro originale il bootloader, ovviamente senza altri componenti esterni.
Manuale "Arduino e le tecniche di programmazione dei microcontrollori ATMEL"
http://www.michelemenniti.it/manuale_di_programmazione.html
http://www.michelemenniti.it/offerta.html
Articoli ElettronicaIN
http://www.michelemenniti.it/elettronica_in.html

minimanimo

#29
Jul 17, 2013, 06:37 pm Last Edit: Jul 17, 2013, 07:10 pm by minimanimo Reason: 1
Salve...c'è stata una svolta: mi sono fatto prestare un'altro arduino Uno R3 da un amico:
Ho messo il micro di questo nella board fallata.. e ha funzionato. Ho provato anche a scrivere un programma direttamente su quella board e funziona bene senza problemi,quindi escludo tutti i problemi di incompatibilità driver dal lato del pc,e inoltre escludo problema del convertitore com2usb (non ricordo bene cosa mi avevate citato qualche post fà). A questo punto è il micro!
Ho caricato come da guida del sito ufficiale,lo sketch per ArduinoISP,fatto i collegamenti col micro da programmare su breadboard (collegamenti senza condensatori e quarzo),provato a programmare ma ecco il risultato:
Code: [Select]

C:\Program Files (x86)\Arduino\hardware/tools/avr/bin/avrdude -CC:\Program Files (x86)\Arduino\hardware/tools/avr/etc/avrdude.conf -v -v -v -v -patmega328p -cstk500v1 -P\\.\COM9 -b19200 -e -Ulock:w:0x3F:m -Uefuse:w:0x05:m -Uhfuse:w:0xde:m -Ulfuse:w:0xff:m

avrdude: Version 5.11, compiled on Sep  2 2011 at 19:38:36
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2009 Joerg Wunsch

         System wide configuration file is "C:\Program Files (x86)\Arduino\hardware/tools/avr/etc/avrdude.conf"

         Using Port                    : \\.\COM9
         Using Programmer              : stk500v1
         Overriding Baud Rate          : 19200
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: Recv: . [14]
avrdude: Recv: . [10]
         AVR Part                      : ATMEGA328P
         Chip Erase delay              : 9000 us
         PAGEL                         : PD7
         BS2                           : PC2
         RESET disposition             : dedicated
         RETRY pulse                   : SCK
         serial program mode           : yes
         parallel program mode         : yes
         Timeout                       : 200
         StabDelay                     : 100
         CmdexeDelay                   : 25
         SyncLoops                     : 32
         ByteDelay                     : 0
         PollIndex                     : 3
         PollValue                     : 0x53
         Memory Detail                 :

                                  Block Poll               Page                       Polled
           Memory Type Mode Delay Size  Indx Paged  Size   Size #Pages MinW  MaxW   ReadBack
           ----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- ----- ---------
           eeprom        65    20     4    0 no       1024    4      0  3600  3600 0xff 0xff
                                  Block Poll               Page                       Polled
           Memory Type Mode Delay Size  Indx Paged  Size   Size #Pages MinW  MaxW   ReadBack
           ----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- ----- ---------
           flash         65     6   128    0 yes     32768  128    256  4500  4500 0xff 0xff
                                  Block Poll               Page                       Polled
           Memory Type Mode Delay Size  Indx Paged  Size   Size #Pages MinW  MaxW   ReadBack
           ----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- ----- ---------
           lfuse          0     0     0    0 no          1    0      0  4500  4500 0x00 0x00
                                  Block Poll               Page                       Polled
           Memory Type Mode Delay Size  Indx Paged  Size   Size #Pages MinW  MaxW   ReadBack
           ----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- ----- ---------
           hfuse          0     0     0    0 no          1    0      0  4500  4500 0x00 0x00
                                  Block Poll               Page                       Polled
           Memory Type Mode Delay Size  Indx Paged  Size   Size #Pages MinW  MaxW   ReadBack
           ----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- ----- ---------
           efuse          0     0     0    0 no          1    0      0  4500  4500 0x00 0x00
                                  Block Poll               Page                       Polled
           Memory Type Mode Delay Size  Indx Paged  Size   Size #Pages MinW  MaxW   ReadBack
           ----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- ----- ---------
           lock           0     0     0    0 no          1    0      0  4500  4500 0x00 0x00
                                  Block Poll               Page                       Polled
           Memory Type Mode Delay Size  Indx Paged  Size   Size #Pages MinW  MaxW   ReadBack
           ----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- ----- ---------
           calibration    0     0     0    0 no          1    0      0     0     0 0x00 0x00
                                  Block Poll               Page                       Polled
           Memory Type Mode Delay Size  Indx Paged  Size   Size #Pages MinW  MaxW   ReadBack
           ----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- ----- ---------
           signature      0     0     0    0 no          3    0      0     0     0 0x00 0x00

         Programmer Type : STK500
         Description     : Atmel STK500 Version 1.x firmware
avrdude: Send: A [41] . [80]   [20]
avrdude: Recv: . [14]
avrdude: Recv: . [02]
avrdude: Recv: . [10]
avrdude: Send: A [41] . [81]   [20]
avrdude: Recv: . [14]
avrdude: Recv: . [01]
avrdude: Recv: . [10]
avrdude: Send: A [41] . [82]   [20]
avrdude: Recv: . [14]
avrdude: Recv: . [12]
avrdude: Recv: . [10]
avrdude: Send: A [41] . [98]   [20]
avrdude: Recv: . [14]
avrdude: Recv: . [00]
avrdude: Recv: . [10]
         Hardware Version: 2
         Firmware Version: 1.18
         Topcard         : Unknown
avrdude: Send: A [41] . [84]   [20]
avrdude: Recv: . [14]
avrdude: Recv: . [00]
avrdude: Recv: . [10]
avrdude: Send: A [41] . [85]   [20]
avrdude: Recv: . [14]
avrdude: Recv: . [00]
avrdude: Recv: . [10]
avrdude: Send: A [41] . [86]   [20]
avrdude: Recv: . [14]
avrdude: Recv: . [00]
avrdude: Recv: . [10]
avrdude: Send: A [41] . [87]   [20]
avrdude: Recv: . [14]
avrdude: Recv: . [00]
avrdude: Recv: . [10]
avrdude: Send: A [41] . [89]   [20]
avrdude: Recv: . [14]
avrdude: Recv: . [00]
avrdude: Recv: . [10]
         Vtarget         : 0.0 V
         Varef           : 0.0 V
         Oscillator      : Off
         SCK period      : 0.1 us

avrdude: Send: A [41] . [81]   [20]
avrdude: Recv: . [14]
avrdude: Recv: . [01]
avrdude: Recv: . [10]
avrdude: Send: A [41] . [82]   [20]
avrdude: Recv: . [14]
avrdude: Recv: . [12]
avrdude: Recv: . [10]
avrdude: Send: B [42] . [86] . [00] . [00] . [01] . [01] . [01] . [01] . [03] . [ff] . [ff] . [ff] . [ff] . [00] . [80] . [04] . [00] . [00] . [00] . [80] . [00]   [20]
avrdude: Recv: . [14]
avrdude: Recv: . [10]
avrdude: Send: E [45] . [05] . [04] . [d7] . [c2] . [00]   [20]
avrdude: Recv: . [14]
avrdude: Recv: . [10]
avrdude: Send: P [50]   [20]
avrdude: Recv:
avrdude: stk500_program_enable(): protocol error, expect=0x14, resp=0x50
avrdude: initialization failed, rc=-1
         Double check connections and try again, or use -F to override
         this check.

avrdude: Send: Q [51]   [20]
avrdude: Recv:
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

avrdude done.  Thank you.


Grazie a tutti veramente :D


EDIT: Aggiornamento:
Stò modificando il circuito mettendo tra il pin 1 e gnd una res da 10 Kohm,tra il reset e gnd un condensatore 10 uF (per disabilitare l'autoreset,o cosi dicono),risultato:
Code: [Select]

################################## | 100% 0.06s

avrdude: Device signature = 0x000000
avrdude: Yikes!  Invalid device signature.
         Double check connections and try again, or use -F to override
         this check.

avrdude: Send: Q [51]   [20]
avrdude: Recv: . [14]
avrdude: Recv: . [10]

avrdude done.  Thank you.


Che cavolo... Il condesatore l'ho messo elettrolitico,ma dal disegno mi sà che era a disco.

Go Up