Go Down

Topic: Problems while burning bootloader (Read 1 time) previous topic - next topic

galabuzi_johnpaul

Hi, am experiencing a major problem while trying to burn the bootloader to my new ATMEGA168 using arduino diecimila.
I read through the arduino website and followed the instructions of burning bootloader using the parallel programmer. Then I assembled the materials together and tried to burn the bootloader which gave me the following errors:

Code: [Select]
avrdude: AVR device not responding
avrdude: initialization failed, rc=-1
avrdude: Yikes!  Invalid device signature.
avrdude: Expected signature for ATMEGA168 is 1E 94 06
avrdude: AVR device not responding
***failed; 
avrdude: verification error, first mismatch at byte 0x0000
         0x00 != 0x07
avrdude: verification error; content mismatch

My OS is window xp. Please help me.

hiduino

When using the parallel programmer it does not provide power to the target, you need to also power the atmega168 separately.


galabuzi_johnpaul

At first I powered the arduino using the USB which never worked. Then I powered it using an adaptor which also did not work. The problem I think must be something else. Thank you.

galabuzi_johnpaul

Something else is that my microcontroller is written ATMEGA168-20PU and am using arduino-0023. Does that have any effect on the bootloading process?

Go Up