Go Down

Topic: Arduino GSM Shield modem doesn't power up (Read 12197 times) previous topic - next topic


Aug 17, 2013, 08:33 pm Last Edit: Aug 17, 2013, 08:43 pm by hugocura Reason: 1
I buyed a Arduino GSM Shield on Arduino Web Store, back in March/2013.
I tested it (examples) and it does everything I want to.

Now, I have my software almost done and the last piece was the GSM part... So I take the shield out of box and started to test it again (with examples on IDE).
Initially, it takes too much time to establish connection to network and give me feedback... I needed to restart the process (resetting) but it ends to work.
But now, a few tests later (in about an hour), the modem doesn't power up anymore. Status LED doesn't light up.

I'm using the shield with original Arduino Mega 2560, Pins 2 and 10 are connected and SIM card is into the bracket. I tested powered Arduino with 9V DC adapter and only by USB port.
With debug enabled, on TestGPRS example, I received this: "AT%13%".

I've read about jumper CTRL/D7 pad, which power the modem. Mine is soldered by default. I can try to remove the solder and use Power button but I don't want to touch anything before an opinion.

Does anyone knows whats the problem?

Thank you


I tryed to use BandManagement example but without success.
Here is the output (I selected option 4):

Restarting modem...
Modem restarted.
Unrecognized modem answer:
Current band:
Want to change the band you’re on?
Select band:
1 : E-GSM(900)
2 : DCS(1800)
3 : PCS(1900)
4 : E-GSM(900)+DCS(1800) ex: Europe
5 : GSM(850)+PCS(1900) Ex: USA, South Am.
6 : GSM(850)+E-GSM(900)+DCS(1800)+PCS(1900)
Configuring band EGSM_DCS_MODE
Error while changing band
Unrecognized modem answer:


Aug 19, 2013, 01:16 pm Last Edit: Aug 19, 2013, 03:43 pm by hugocura Reason: 1
Today I tried to power up the shield again.
It really started like a normal, but only once :(
When modem tries to reconnect (first connection was successfully done), status LED goes off and never light up again. I removed power cable and tried connected it again... nothing.



The shield has a Power button, did you try with it?. Can you try to test shield with Arduino UNO?.

You can do a sketch for power on modem setting CTRL pin in HIGH for 10 seconds. For example, try with this sketch:

Code: [Select]

#include <SoftwareSerial.h>
#include <string.h>

char incoming_char = 0;
SoftwareSerial cell(2,3); // check GSM RX and GSM TX matches with digital 2 and digital 3 pin.

void setup()
  // Initialize serial ports for communication.

  // Reset
  Serial.println("Start Reset");
  pinMode(7, OUTPUT);
  digitalWrite(7, HIGH);
  digitalWrite(7, LOW);
  Serial.println("End Reset"); 


  Serial.println("Enter your AT commands (with CR & NL)...");

void loop()
  if(cell.available() > 0)
    incoming_char = cell.read();
    if((incoming_char >= ' ') && (incoming_char<='z'))
      Serial.print((int) incoming_char);
      if(incoming_char == 10)

  if(Serial.available() > 0)
    incoming_char = Serial.read();

When serial monitor shows Enter your commands, you have to try with AT commands, with NL & CR configuration and 9600 bps. The modem should respond.


Aug 29, 2013, 12:13 pm Last Edit: Aug 29, 2013, 12:15 pm by hugocura Reason: 1
Thank you for your reply.

I tested with UNO and I already tried to remove solder from CTRL/D7 to use Power button. The symptoms are the same.

I tested your code. The modem started and responded (indicator LEDs worked properly).
After 2 resets, the process failed. Your code is listening commands on shell but indicator LEDs are both off, and the modem isn't responding...

If I try this today again, probably I can't get nothing. If I will test tomorrow, maybe the modem starts one time. I really don't know whats going on. Maybe an intern defect, don't know.


Does anyone can give me a "privileged" contact? Someone inside Arduino team...

I have a ticket waiting since the day I opened this thread... The status is the same for weeks: "This request is currently being processed by our staff".

I still have my GSM Shield with the same problems... :(



I'm having the same issue ( basically the status led does blink only 5-6 times when I first power it up but then is completely OFF)
did you finallu solve it?
any hint would be much appreciated



When I have experienced this with SIM900 shields it's because of a lack of power.


I tried by powering the UNO with 12V 1.25A and then by powering only the shield itself (through Vin, unplugged from the UNO) with the same power supply, but nothing new happened.



related question; how to read the AT commands reply from the Quectel like %12%h%%132...??

I tried with version 1.0.4 and 1.5.8

Go Up