Go Down

Topic: Problema de corrosion con sensor de humedad de suelo (Read 2815 times) previous topic - next topic

NovatoPro-87

Hola a toda la comunidad, es la primera vez que escribo al foro oficial de arduino y espero que alguien por favor me pueda responder:

Mi duda es ¿Cómo solucionar el problema de la corrosión del sensor de humedad? El sensor usa el modulo HL-69, y el sensor seria este
     
en esta foto esta tanto el modulo como el sensor)

Según yo, este sensor se basa en el principio de conducción, al meter el sensor a la tierra una de la patas es energizada y si la otra pata se energiza entonces hay conductividad y por lo tanto significa que hay humedad en la tierra.

Y bueno mi problema es que, estaba haciendo unas pruebas para mi proyecto de un regador automático de plantas, y al cabo de una sema retire el sensor de la tierra y este estaba corroído, tenia demasiado oxido, entoces esto es un problema que debo de resolver pero no se muy exactamente como.

Mi primera solución es bañar de cobre (con un baño electroquímico) al las patas del sensor, dando una resistencia extra a la oxidación.

O otra solución seria darle un delay al sensor (como de unos 30 seg), porque, al no tener delay, arduino sigue enviando energía eléctrica y por lo tanto el sensor hace una electrolisis al agua que esta en la tierra y provocando una oxidación en una de las patas del sensor de humedad. Poniendo un delay estoy pausando el pulso de energía y por lo tanto evitando la oxidación.

O mi otra solución seria hacer un sensor de humedad de tierra resistente a la corrosión pero el problema es que no se hacer xD.

Y mi pregunta a la comunidad seria, ¿Cuál solución escojo? O saben como hacer un sensor de humedad casero resistente a la corrosión, o simplemente pueden decir otra solución, estaría agradecido de leer sus respuestas, Saludos!

elduino

Hola NovatoPro-87  , yo estoy también metido en un proyecto de riego automático ( es que somos legión jajaja), yo aun no lo he puesto en funcionamiento serio,  y por lo tanto no he notado oxidaciones graves, aunque no las descarto y por eso te comento las actuaciones que tengo previstas, por si te sirven de ayuda.
  • Desconectar los sensores mientras no este midiendo.
  • Espaciar lo mas posible los tiempos de medida, yo inicialmente tenia previsto medir cada 6 horas pero creo que lo voy a dejar en 8 horas.
  • Si la duración de las puntas enterradas es demasiado corta, las sustituiría por dos clavos, acero inoxidable, aluminio o en ultimo caso ferrita... las puntas son meros conductores no tienen ningún circuito electrónico asociado.

El cobre no te lo recomiendo, según he oído, aunque en pequeñas cantidades es necesario para las plantas su exceso puede ser dañino.

carlap

hola. yo tengo el mismo problema de corrosión de los sensores , y tenia pensado usar pintura de teflon pero con adherencia al plástico, saben de algo similar? gracias

surbyte

La solución es no consultar por el estado de humedad tan seguido, hacerlo cada tanto tiempo. Si el sistema esta permanentemente alimentado entoces no serivirá de nada lo que te digo.
La solución es usar un switch o rele que desconecte la alimentación cuando no midas.



La humedad no cambia a cada segundo de modo que establece un criterio de medición.

Puedes medir cada 10 min o cada 30 min o tan espaciado como 2 veces por dia, y si debes tomar una decisión pues incrementa la frecuencia de lecturas.

Como se ve en el esquema, tienes que alimentar el sensor y para ello una opción es comandarlo con un rele.
Pero otra solución es usar un MOSFET canal P que haga de llave digital. Asi cuando lo necesites activas el MOSFET, esto alimenta el sensor y de ese modo evitas o minimizas la electrólisis que indefectiblemente ocurrirá al estar siempre conectado.




GO_zalo

Hola!

Yo puedo aportar una experiencia profesional interesante al respecto, pero que os hará descartar ese módulo si lo que quieres evitar es la corrosión

Lo que hice fue montar con pura electrónica una fuente de pulsos de +/-3V y no me refiero a 3 voltios aproximadamente sino a una fuente que vaya de -3 a 3 voltios

Ese tipo de señal evita la corrosión luego sólo haya que medir la corriente que pasa usando una pequeña resiste en serie con la maceta

Resultado funcionó un año sin apenas corrosión comparándolo con los mismos electrodos enterrados al lado, con el propósito de poder comparar justamente

Es mucha más faena diseñar y montar eso pero es un buen trabajo. B

elduino

buena idea, GO_zalo, llegaste a experimentar con corriente alterna?

GO_zalo

Si, lo probamos y funcionó muy bien, no puedo subir nada por que era de un trabajo anterior, además que no lo tengo ya en mi poder el esquemático ni los componentes que cogí lo siento

elduino

Muchas gracias, era sobretodo curiosidad, ya solo nos falta que algún botánico nos diga si a las plantas les molesta ese paso continuo de corriente, pienso que no al estar muy localizado peroo....

Go Up