Go Down

Topic: Arduino Yun Dongle Stop Working  (Read 652 times) previous topic - next topic

ctorregrosa

Hi, I'm currently working with an Arduino yun and a Huawei E173 dongle. Apparently everything goes well, but after a few hours the arduino yun stops communicating with the dongle and the only way to solve the problem is to unplug and plug the dongle.

For now I have done the following:

  • I configured the dongle according to the guide: https://wiki.openwrt.org/doc/recipes/3gdongle and some youtube videos.
  • When the dongle works I have internet access and the SD card /mnt/sda1 or /mnt/sdb1 (random). I can also connect and disconnect the dongle using the ifup wan-3g / ifdown wan3-g command (wan-3g is the dongle network) and it works.
  • When the connection fails, I do not have access to Internet or SD card.
  • When I run ifdown wan-3g then ifup wan-3g the network does not get up.
  • The data and energy line are separate. When I re-plug the data line the problem is solved, but not when I re-plug the power line.
  • I tried using the lsusb command and then usbreset 001/0XX but it does not solve the problem.
  • I tried restarting the network, but it did not fix the problem

I would appreciate if someone could help me to solve this problem or some idea of ​​connecting and reconnecting the dongle by commands

Thanks.

sonnyyu


Go Up