Go Down

Topic: Seeing Yun in IDE Port menu (Read 64907 times) previous topic - next topic

pasluc7469

walking araund the windows firewall, i noticed that in Control Panel > Windows Firewall > advanced settings > output Connection Rules is completly empty....



Could it be that the issue??? If yes, how can i solve that????

Thanks in advance...

sonnyyu

#61
Feb 10, 2015, 07:53 am Last Edit: Feb 10, 2015, 08:24 am by sonnyyu
...
i can connect to arduino via ssh, arduino.local via browser, via winscp, and via usb by ide.
bonjour browser shows the arduino yun.... works fine

_arduino._tcp (Arduino)
_ssh._tcp.(Secure Shell on Arduino)
This means bonjour service as well as firewall is OK. now either Java or IDE is problem, worse case is Windows.
firewall is OK

Restore Windows ( reboot)
Complete uninstall Java  ( reboot) and Arduino IDE   ( reboot)

After uninstall Java and IDE

manually clean files installed by Arduino IDE if leftover:

Code: [Select]
libusb0.dll (by http://libusb-win32.sourceforge.net) - LibUSB-Win32 - DLL
cygwin1.dll (by Red Hat) - Cygwin (Cygwin® POSIX Emulation DLL)
arduino.exe
cygiconv-2.dll
rxtxSerial.dll
uninstall.exe


manually clean files installed by Java:

manually clean registry after a failed Java uninstall:

manually clean registry after Uninstall Arduino IDE:


Re-install latest  version Java  ( reboot) and Arduino IDE  ( reboot)


The worse case is  re-install windows, if you have no windows backup or ghost image.

As soon as You get it works, backup windows, in future any error restore will do the trick.










pasluc7469

after 7 very long days, i decided to buy another hard disk, and re-installed windows ( this time i installed windows 7 ultimate instead of home premium).
As sonnyyu suggested, in my case it could be an OS error, that didn't let me connect arduino IDE port to the yun's IP. Now, it seems to work all fine!!!!

Special thanks to sonnyyu for supporting me!!!

muzamil110

hi

i am also facing same problem i have Enabled port 5353 still it is not show ip in IDE

muzamil110

hi

i am also facing same problem even i have installed bojour and unblock the port 5353 , Still no ip address in IDE ?

nickgammon

@muzamil110: Please start your own thread about this and describe in detail the issue. You are cross-posting in other threads.
Please post technical questions on the forum, not by personal message. Thanks!

More info: http://www.gammon.com.au/electronics

sonnyyu

CentOS release 6.6 (Final)'s IDE Port menu:

Centos is conservative and enterprise-level OS, kernel is behind.

Code: [Select]
[root@localhost ~]# cat /etc/redhat-release
CentOS release 6.6 (Final)


Code: [Select]
yum update

get Yun product id and vendor id:

Code: [Select]
lsusb
...
Bus 002 Device 004: ID 2341:8041 Arduino SA


Code: [Select]
lsmod|grep cdc_acm

nothing show means kernel driver for cdc_acm is  not loaded.

load kernel driver:

Code: [Select]
modprobe cdc_acm

Test:

Code: [Select]
ls -l /dev/ttyACM0

Port no show due to product id and vendor id is not in cdc_acm.c

Code: [Select]
nano /etc/rc.modules
modprobe cdc_acm
echo "0x2341 0x8041" > /sys/bus/usb/drivers/cdc_acm/new_id

chmod +x /etc/rc.modules



Load user(sonnyyu) into group dialout:

Code: [Select]
usermod -a -G  dialout sonnyyu

Code: [Select]
reboot

confirm driver installed:

Code: [Select]
[root@localhost ~]# ls -l /dev/ttyACM0
crw-rw----. 1 root dialout 166, 0 Apr  8 01:17 /dev/ttyACM0



Download IDE 1.6.1 and test it.

from IDE 1.6.2, there is small glitch, it required start IDE twice after machine reboot then runs  normal.







sonnyyu

#67
Apr 08, 2015, 06:08 pm Last Edit: May 04, 2015, 03:53 pm by sonnyyu
CentOS release 7.1.1503's IDE Port menu:

Code: [Select]
yum update

Code: [Select]
cat /etc/redhat-release
CentOS Linux release 7.1.1503 (Core)


Code: [Select]
lsmod|grep cdc_acm
cdc_acm                32971  0


Code: [Select]
ls -l /dev/ttyACM0
crw-rw----. 1 root dialout 166, 0 Apr  8 01:17 /dev/ttyACM0


Code: [Select]
usermod -a -G  dialout sonnyyu

Code: [Select]
reboot

Download IDE 1.6.1 and test it.

from IDE 1.6.2, there is small glitch, it required start IDE twice after machine reboot then runs  normal.


New kernel save a lot of time!




sonnyyu

Installing Arduino IDE at Linux:

https://learn.sparkfun.com/tutorials/installing-arduino-ide/linux

  • ArchLinux
  • Debian
  • Fedora
  • Gentoo
  • MEPIS
  • Mint
  • openSUSE
  • Puppy
  • Pussy
  • Slackware
  • Ubuntu
  • Xandros (Debian derivative) on Asus Eee PC






sonnyyu

#69
May 04, 2015, 12:30 pm Last Edit: May 04, 2015, 03:52 pm by sonnyyu
If Yun is at internet, Bonjour is only local area network protocol and Yun would not be shown on network port.  The only way Seeing Yun in IDE network Port menu is  Bonjour proxy server.

Here is the way to make it happen:


Turn off Bonjour service at Yun:

Code: [Select]
/etc/init.d/avahi-daemon stop
/etc/init.d/avahi-daemon disable



Run it at windows command line or Mac  (at same IDE machine).

Code: [Select]
dns-sd -P Arduino _arduino._tcp local 80 arduino.local 192.168.0.102 board=yun distro_version=0.1
dns-sd -P Arduino _arduino._tcp local 80 arduino2.local 192.168.0.122 board=yun distro_version=0.1


Either public or private IP address dependent direct connect or behind NAT.


dns-sd.exe comes with Bonjour for Windows, install from here:

http://forum.arduino.cc/index.php?topic=188101.msg1554795#msg1554795





ShapeShifter

Code: [Select]
dns-sd -P Arduino _arduino._tcp local 80 arduino.local 192.168.0.102 board=yun distro_version=0.1
dns-sd -P Arduino _arduino._tcp local 80 arduino2.local 192.168.0.122 board=yun distro_version=0.1
The downside with this is that you either need to set up the Yun's with explicit static addresses, static DHCP rules, or you need to enter these commands any time the address changes. The whole point of Bonjour is zero configuration, and this is hardly zero effort. It's a work-around at best. The IDE needs a better way to find Yun's, the current method is far too fragile and asking people to jump through hoops is not reasonable.

sonnyyu

#71
May 04, 2015, 03:32 pm Last Edit: May 04, 2015, 03:48 pm by sonnyyu
...
The downside with this is that you either need to set up the Yun's with explicit static addresses, static DHCP rules, or you need to enter these commands any time the address changes. The whole point of Bonjour is zero configuration, and this is hardly zero effort. It's a work-around at best.
...
This method for Yun with public IP address, normally with explicit static addresses and no DHCP. Bonjour is only local area network protocol. No we are in wide area network.




sonnyyu

#72
May 04, 2015, 03:47 pm Last Edit: May 04, 2015, 03:50 pm by sonnyyu
...
The IDE needs a better way to find Yun's, the current method is far too fragile and asking people to jump through hoops is not reasonable.
...
It is true from field report IDE has unreliable Bonjour discover service. but same time USB discover is far reliable.
The main difference between USB discover and Bonjour discover is first one  use JNI (Java Native Interface). C is still killer program language. :P




thataintworking

If Yun is at internet, Bonjour is only local area network protocol and Yun would not be shown on network port.  The only way Seeing Yun in IDE network Port menu is  Bonjour proxy server.

Here is the way to make it happen:


Turn off Bonjour service at Yun:

Code: [Select]
/etc/init.d/avahi-daemon stop
/etc/init.d/avahi-daemon disable



Run it at windows command line or Mac  (at same IDE machine).

Code: [Select]
dns-sd -P Arduino _arduino._tcp local 80 arduino.local 192.168.0.102 board=yun distro_version=0.1
dns-sd -P Arduino _arduino._tcp local 80 arduino2.local 192.168.0.122 board=yun distro_version=0.1


Either public or private IP address dependent direct connect or behind NAT.


dns-sd.exe comes with Bonjour for Windows, install from here:

http://forum.arduino.cc/index.php?topic=188101.msg1554795#msg1554795

I am running OS X Yosemite and I never saw the Yun IP show up in the IDE Ports menu. This does the trick for me. This is definitely not an ideal solution, but at least it works.

Thanks, sonnyyu!

jessemonroy650

hi there, i have discovered that this issue is particularly problematic when the wifi signal is "weak" or average at best (like 2 bars), can anyone verify this? on stronger signals (3-5 bars) i don't encounter this problem of not seeing the YUN ip address in the IDE Ports menu.

i have concluded that it is indeed an IDE problem because i can ping the YUN's ip add as well as connect to it via the browser but no such luck with the IDE, i'd have a hard time uploading sketches to it.

i hope there is a way to resolve this. sonnyyu, i have done everything you instructed but no improvement :(
Use the USB port. or move closer the the AP.

Jesse

Go Up