Go Down

Topic: Configurating the Yun as Client (Read 6994 times) previous topic - next topic

sth77

Hello! I'm a proud owner of the new Arduino Yun. The Yun works very fine as an access point, but I tried several times to configurate the Yun as a "normal" wlan-client, but every time I was locked off. So the only way to try it again was to press the reset-button for more then 30 seconds.   :(
Is there any tutorial for this? Is someone able to explain the steps I have to do? It would be very nice...
Mein verwaister Arduino-Blog: http://www.sth77.de/ - letzter Eintrag: Diamex-ISP in der irgendwann mal aktuellen Arduino-IDE 1.6.4

wayoda


sth77

Yes, I did. But I think thats not enough to configure the as a client. I think I have to use LUCI to configurate the settings, but I'm really confused about the complexity.
Mein verwaister Arduino-Blog: http://www.sth77.de/ - letzter Eintrag: Diamex-ISP in der irgendwann mal aktuellen Arduino-IDE 1.6.4

Jantje

it workd fine for me.
You have to connect to the same wireless router from your PC. If you can not do so you have to configure your wireless router as a bridge.
I've used both and both worked fine.
Best regards
Jantje
Do not PM me a question unless you are prepared to pay for consultancy.
Nederlandse sectie - http://arduino.cc/forum/index.php/board,77.0.html -

federicofissore

Hi sth77
a couple of questions:
- does the wlan led keep on blinking after configuring the wifi?
- if it doesn't, have you tried running example sketch WifiStatus
- if it does, once the yun reboots (after 60 seconds since the wlan led starts blinking) and gets back as an access point, accessing the webpanel again should show a text area saying "sorry" and inviting you to check out the log file: can you attach it to the thread?
- what's the model of your hotspot?

sth77

#5
Sep 18, 2013, 10:38 pm Last Edit: Sep 18, 2013, 10:44 pm by sth77 Reason: 1
What I did is:
I connected my tablet with the wireless arduino network, entered the password "arduino" and clicked the button "configure". I choosed my wireless network and entered my wlan-password. With a click on "Configure&Restart" ther ist a message "Confiruration saved! I'm restarting." and a progress bar is filling.
Sadly the wlan-led on the board is not glowing and there is no entry in the client list of my router-setup.


Hi sth77
a couple of questions:
- does the wlan led keep on blinking after configuring the wifi?

As written ahead, theres no blinking


- if it doesn't, have you tried running example sketch WifiStatus
- if it does, once the yun reboots (after 60 seconds since the wlan led starts blinking) and gets back as an access point, accessing the webpanel again should show a text area saying "sorry" and inviting you to check out the log file: can you attach it to the thread?

I will test it immediately.


- what's the model of your hotspot?

It is a Belkin N1. My password contains numbers, letters but also special characters like "@". Could this be a problem?

Thanks for your answers!
Mein verwaister Arduino-Blog: http://www.sth77.de/ - letzter Eintrag: Diamex-ISP in der irgendwann mal aktuellen Arduino-IDE 1.6.4

federicofissore

Please try flashing the wifistatus example sketch (via serial, not wifi), open the serial monitor and see if it gets an IP address
After rebooting, the wlan led doesn't immediately start blinking, it takes 30 seconds or so
If nothing helps, flash the yun serial terminal example, reboot the ar9331 and attach the output to the thread

sth77

Wow, it works! Maybe I was to impatient.

Code: [Select]

Current WiFi configuration
SSID: Belkin_N1
Mode: Client
Signal: 100%
Encryption method: WPA2 PSK (NONE)
Interface name: wlan0
Active for: 15 minutes
IP address: 192.168.2.13/255.255.255.0
MAC address: 90:A2:DA:F0:05:45
RX/TX: 461/92 KBs


Once more: Thank you guys!

[edit] The blue WLAN-led is still not blinking...
Mein verwaister Arduino-Blog: http://www.sth77.de/ - letzter Eintrag: Diamex-ISP in der irgendwann mal aktuellen Arduino-IDE 1.6.4

Go Up