Go Down

Topic: Bridge between eth1 and wifi (Read 9515 times) previous topic - next topic


Hello now I can ping the machine. But I can not connect to the web server ( I think it is the fault of the protection of the wifi.


Test with firewall off:

Code: [Select]
/etc/init.d/firewall disable
/etc/init.d/firewall stop




Hello now I can ping the machine. But I can not connect to the web server ( I think it is the fault of the protection of the wifi. which box?


I apologize for the inconvenience, but I don't have any experience with this kind of thing, it's my first project.

Now works. I simply set a fixed IP on the WiFi card of my PC . Now it works correctly .


Apr 02, 2019, 06:01 pm Last Edit: Apr 02, 2019, 06:15 pm by bijay_karki
i created the mesh network on arduino yun (supports openwrt). initially opkg update works fine, but after configuration of mesh is done; opkg update does not work. each of nodes has internet access if checked from web browser(computer connected to node as client) and luci works fine too. all ping also works fine as above. but opkg update and opkg install does not work; also this device doesnot have wan6 (disabling wan6 can help in some devices)

checked many places they say opkg update fails if network does not have internet access( which i have and ping also works) or /etc/config/network is not configured well ( how would i get internet access if configuration was not ok)...?

Also if i check from luci i can see that Wan interface is down (due to bridge between eth0 and eth1) but internet works fine.

my connection configuration is:
internet-------------ISP router( internet port of d link ac1200)( (wired ethernet to eth1 of Yun 1)----node1(eth0=wifi, eth1=wired ethernet)

for above problem i tried multiple options:

a) turn of bridge between lan(eth0 and bat0) and wan(eth1 wired ethernet from internet router) then opkg update works i.e..,device(node) gets internet for itself from wan(wired ethernet) but internet on lan(wifi) is off......during this time lan and wan has separate ip(wan given by dhcp of dlink router and lan with static as specified above)

b) continue with bridge; ip of wan(wired ethernet) disappears (even though interface remains up) but wifi has internet with static ip as specified above.


Strange as it may seem, but another reason for opkg update to fail is if the Yun is not set to the correct time and time zone.


Apr 03, 2019, 09:19 pm Last Edit: Apr 03, 2019, 09:20 pm by bijay_karki
the problem was with DNS server address so giving DNS server address as your internet providing router address or google address( ) will solve this problem).
Also give gateway address (your router address)

Go Up