Go Down

Topic: connect YUN via Internet? (Read 9382 times) previous topic - next topic


I would like to connect to yun using IDE via internet connection (I can redirect ports on my router), please let me know how to do it, and what ports should I redirect?

thx

federicofissore

Hi.

It's not currently possible as it would require to manually specify an IP address. We have the feature in our todo list but we still haven't prioritized it

jake1981

Maybe you could give YUN a static IP in your LAN, then if you have your lan made with openwrt, you could add a package that would use dynamic dns services to give your online IP a name in the internet that would follow your changing IP.. Then there's the security issue- you could install VPN server and this way it should work..

A lot of work and reading, but can be done..

warwound

Can't you just assign the YUN a static IP address on your router, forward port 80 to that static IP address and finally use a service such as no-ip.com to give your ISP assigned external IP address an alias?

I wonder if the Yun webserver can be made to run on a port other than 80.
I have apache running on port 80 on my main PC, if i could get the Yun webserver to run on say port 8080 then i could hopefully access both webservers from 'the cloud'.

Martin.

warwound

Yes it works!

1) I set a static IP address for my YUN on my router (i actually assigned a static IP address for each interface wlan0 and eth1).

2) On my router forwarded port 80 to the YUN static IP address - i forwarded port 80 to the wlan0 interface.

3) On my mobile i disabled wifi so it would use mobile internet instead of my local network.

4) On my mobile opened the browser and entered my no-ip.com alias.

Success - the browser showed the YUN login screen, i logged in and could browse the web interface.
Now how to modify the YUN web server so it listens on a port other than port 80...?

FYI i also modified my HOSTS file, giving each YUN interface a local alias:

Quote

192.168.1.106   yun-wlan0
192.168.1.107   yun-eth1


Martin.

warwound

I would like to connect to yun using IDE via internet connection


Just noticed i misread the OP!

Anyway for anyone that's followed my last couple of posts it looks like it is possible to reconfigure the Yun webserver to listen on a different port, in fact it looks as though the Yun webserver can listen on more than one port at a time.
More info here: http://playground.arduino.cc/Hardware/Yun#running_two_websites and http://wiki.openwrt.org/doc/uci/uhttpd.

Martin.

ProfePaco

I am running the Client Pixel example with no problem in the local intranet.  Now I would like to run it from the Internet.

I have an account at no-ip. Let's say the host is  "name.no-ip.biz·. If I ping name.no-ip.biz, I see it works. Nice!

I set up a static ip to my arduino Yun. 192.168.0.105. I see is a permanent ip for arduino yun's MAC. Nice!

The DMZ host in the router is the arduino IP: 192.168.0.105. OK!

Running putty root@192.168.0.105 port 22 works well, as this is run in the intranet. Yun is asking me the password. OK!

So now let's try root@name.no-ip.biz port 22. It does not work. So, what is wrong?

Thanks!!!

lucad79

Hi

check the configuration of your router... some routers have a "DMZ" zone but placing a host in that zone is not enough: you must also configure the correct port forwarding and firewall rules to let the incoming packets (to port 22 = SSH) be routed to the host.

ProfePaco

#8
Dec 01, 2013, 09:37 pm Last Edit: Dec 01, 2013, 09:43 pm by ProfePaco Reason: 1

Hi

check the configuration of your router... some routers have a "DMZ" zone but placing a host in that zone is not enough: you must also configure the correct port forwarding and firewall rules to let the incoming packets (to port 22 = SSH) be routed to the host.


Thanks for your interest.

Please have a look to the information displayed from my router:





I think everything seems OK.

BTW, I saw that in arduino.local there some options for a firewall. Could be this the problem?

Thanks in advance,

lucad79

yes it seems ok... and the local firewall running on Linino can't be the problem if you're able to connect to SSH when in LAN.
mmm are you sure the DynDNS record is updated? Could you try to connect using the public IP of your connection instead of the dynamic DNS record?

ProfePaco


yes it seems ok... and the local firewall running on Linino can't be the problem if you're able to connect to SSH when in LAN.
mmm are you sure the DynDNS record is updated? Could you try to connect using the public IP of your connection instead of the dynamic DNS record?

Thanks for your interest.

The problem is worst than I thought. It does not matter if I use no-ip or the public IP of the router (i.e. the IP of the all computers connect to the router). It does not work.

Furthermore, I redirected port 80 to the IP of Yun. However, I cannot access to the configuration page of Yun using no-ip or using the public IP.

So nothing is working.  :~

lucad79

mmm probably we're missing something at the router level... try to disable the DMZ feature and leave only the virtual server config...

ProfePaco


mmm probably we're missing something at the router level... try to disable the DMZ feature and leave only the virtual server config...


Yes, I did that yesterday with no succes....

no ssh, no 80 port...

is it sure that the configuration firewall page of Yun cannot help?

lucad79

well if you're able to connect to that using a PC in your LAN, the internal firewall is ok... and it can't detect (your router performs a NAT) if the incoming connection is from internet...

ProfePaco

The problem is the router, it seems it is not accepting access from Internet, even I selected the option to do it.

I changed the management port of the router to 100 (previous 80, but 80 is now for Yun). I find the IP of the router: 84.126.XXX.XXX

So i try to connect to the router 84.126.XXX.XXX:100 and to the yun 84.126.XXX.XXX:80 with no success

And ping to 84.126.XXX.XXX only works locally , no when I am connected to another network. So this is clear, router is completely closed

Go Up