Go Down

Topic: Problem with SimpleAudioPlayer diagram (Read 1 time) previous topic - next topic

cdnthought

http://arduino.cc/en/Tutorial/SimpleAudioPlayer

When I (a newb) tried to follow the above page, I found several inconsistencies which have caused much confusion.  I'm hoping that either a) I can help fix the inconsistencies or b) the community can educate me as to why it actually does make sense.

For starters, I'm not a schematics man, but the schematic on that page doesn't appear to match the breadboard graphic:
http://arduino.cc/en/uploads/Tutorial/LM386_AudioDue.jpg
http://arduino.cc/en/uploads/Tutorial/LM386_AudioDue_fritzing.jpg
Notice, for example, how the schematic shows pins 1 and 8 connected via 10uf Capacitor,  The breadboard has pins 2 and 7 connected instead.  Also, the 250uf capacitor is shown inline with the speaker + from pin 5 in the schematic, but the breadboard graphic shows the capacitor linking pins 5 and 6.

Sensing that one or the other was wrong, I did some research online as best I could being a newbie, and came across someone else's "working" version of the wiring:
http://dmstudios.net/misc/lm386/LM386_amp_circuit_layout3.jpg
This version seems to match the schematic.

So, can we confirm that the breadboard graphic is flawed in several ways.

Or, am I not understanding that the breadboard diagram is one correct interpretation of the schematic?

Cheers,
Courtney

nickgammon

The Fritzing diagram looks completely wrong to me, as you have pointed out.
Please post technical questions on the forum, not by personal message. Thanks!

More info: http://www.gammon.com.au/electronics

nickgammon

I have raised a bug report, thanks for pointing it out:

https://github.com/arduino/Arduino/issues/1628
Please post technical questions on the forum, not by personal message. Thanks!

More info: http://www.gammon.com.au/electronics


Go Up