Go Down

Topic: Arduino Uno R3 - non più riconosciuto da pc (Read 2509 times) previous topic - next topic

Zio_Sam

Oct 19, 2013, 11:24 am Last Edit: Oct 19, 2013, 11:27 am by Zio_Sam Reason: 1
Buongiorno a tutti!
vi chiedo per favore un aiuto perchè è tutta la mattina che ho un problema e non ci vengo più fuori..  =(
Ho una scheda Arduino Uno Rev. 3 che uso ormai da un po' di tempo..
E' sempre funzionata bene, e funziona tuttora con uno sketch che avevo caricato quasi 2 mesi fa..
In pratica era una sorta di asta per il fantacalcio con display lcd i2c, 3 led, un buzzer e 2 pulsanti...
oggi volevo sostituire lo sketch con un altro per fare un altra cosa, ma qui la cattiva notizia: il pc non mi rileva più l'Arduino, calma piatta: dall'usb arriva solo alimentazione e nessun segnale.
Premetto che la scheda funziona perfettamente con il programma che ho uploadato in precedenza. I led che rimangono accesi sono quello di alimentazione (ON) e quello arancione (L) sopra i led tx e rx
Ho già provato a:
- provare a collegare al pc la scheda a vuoto (senza i componenti)
- provare a collegare la scheda con i componenti
- cambiare pc e sistema operativo, e la situazione è sempre la stessa
- provare a re-installare i driver
- seguire guide in linea, ma le soluzioni che davano richiedevano comunque di caricare uno sketch sulla scheda, e io di fatto non ci riesco perchè non mi viene riconosciuta la porta seriale...

vi chiedo quindi se qualcuno si è già imbattuto in questa situazione, che non riesco proprio a spiegarmi, e potrebbe darmi una mano per risolvere il problema o comunque sbloccare la porta usb dell'Arduino...   :(
Grazie mille!

prova a fare la manovra di emergenza, e fammi sapere.
http://playground.arduino.cc/Italiano/Pobleminoti
Arduino UNO starter kit.

Zio_Sam

ho provato più volte con la manovra di emergenza, ma non riesco perchè di fatto il pc non riconosce la porta seriale sulla quale fare l'upload del programma...
mi da "Porta seriale COM non trovata"
Code: [Select]
processing.app.SerialNotFoundException: Porta seriale 'COM4' non trovata. Controllate la porta in Strumenti > Porta seriale.
at processing.app.Serial.<init>(Serial.java:191)
at processing.app.Serial.<init>(Serial.java:77)
at processing.app.debug.Uploader.flushSerialBuffer(Uploader.java:77)
at processing.app.debug.AvrdudeUploader.uploadViaBootloader(AvrdudeUploader.java:174)
at processing.app.debug.AvrdudeUploader.uploadUsingPreferences(AvrdudeUploader.java:67)
at processing.app.Sketch.upload(Sketch.java:1671)
at processing.app.Sketch.exportApplet(Sketch.java:1627)
at processing.app.Sketch.exportApplet(Sketch.java:1599)

mhm non saprei...
non è che magari hai messo in corto qualche pin e lo hai bruciato?
che versione usi dell'I.D.E?
Arduino UNO starter kit.

Zio_Sam

ho usato la 1.0.3 e la 1.0.5, ma con ciascuna non funziona..
per il discorso dei pin non saprei, non credo, sembrano funzionare tutti bene (almeno quelli utilizzati nell'ultimo sketch)
credo che il problema sia nella parte di trasmissione all'usb.. non c'è un modo per sbloccare tutto tipo resettare il programma caricato sul microprocessore tramite qualche manovra con i jumper o qualcosa di simile?

puoi riprogrammare l'ATmega, ma ti serve un altro Arduino o un programmatore esterno..
Arduino UNO starter kit.

Zio_Sam

giusto! in effetti la scheda non è da buttare perchè funziona, e se spostassi l'atmega su un altra board per programmarlo, e dopo riportarlo su questa dovrebbe funzionare...
piuttosto stavo pensando, che sia partito il chip mega 16U2? è quello che si occupa della trasmissione?

PaoloP

Per riprogrammare il 16U2 devi usare FLIP --> http://arduino.cc/en/Hacking/DFUProgramming8U2

icio


Zio_Sam


Per riprogrammare il 16U2 devi usare FLIP --> http://arduino.cc/en/Hacking/DFUProgramming8U2

ho provato a usare FLIP, mettendo i jumper ecc.. ma lo stesso non me lo vede, mi da problemi con driver e dll... mah mistero...
quello che mi fa strano è che l'ultima volta che l'ho programmato andava bene e poi boh, partito... :~

Go Up